0

In order to fix the issues (as described by another user on Launchpad with the Gigabyte AM4 Motherboard, I installed a modified 4.10.3 kernel with CONFIG_PINCTRL_AMD disabled. I downloaded it from here. After booting with this kernel, everything worked fine. But now the system frequently crashes and there are a few weird things in /var/log/syslog:

1.

May  1 13:37:55 Ava gnome-software-service.desktop[3074]: 11:37:55:0582 GLib g_strv_length: assertion 'str_array != NULL' failed

These messages appeared very often, but they could be entirely due to Budgie (version 10.3.1) and its integration with gnome programs being buggy.

2.

May  1 13:41:28 Ava budgie-panel.desktop[2987]: process 3387: arguments to dbus_connection_unref() were incorrect, assertion "connection->generation == _dbus_current_generation" failed in file ../../dbus/dbus-connection.c line 2794.
May  1 13:41:28 Ava budgie-panel.desktop[2987]: This is normally a bug in some application using the D-Bus library.

This line, with different ../../dbus/dbus-connection.c lines, makes up more than half of the syslog.

  1. On startup, this line, with different addresses, appears hundreds of times:

    May  1 17:07:59 Ava kernel: [    1.069692] AMD-Vi: Event logged [
    May  1 17:07:59 Ava kernel: [    1.069693] IO_PAGE_FAULT device=09:00.0   domain=0x0003 address=0x000000f4007def00 flags=0x0010]
    

At the end of this block of messages is says:

May  1 17:07:59 Ava kernel: [    1.111308] [AVFS] Something is broken. See log!

I have a RX 480 and I had previously tried to install the AMDGPU-PRO driver, which didn't work, so I removed it with amdgpu-pro-uninstall.

Booting with the modified 4.11-rc8 kernel from the Launchpad Bug thread (linked above) results in the same IO_PAGE_FAULTS as above, although I have not encountered any of the other issues yet.

I will try the new modified 4.11.0 kernel from Launchpad.

2

There is a bug in Ryzen CPUs (or a bug in GCC, depending on who you ask). Any linux code compiled with GCC 4.x or GCC 5.x will possibly create random segfaults. Installing GCC 6.3 can solve some problems: https://www.reddit.com/r/Amd/comments/6crru5/linux_instability_on_ryzen_7/dhwz8pn/?context=3

But you'll likely have to recompile some of your distro. From what I've heard, the problems originate in the bash shell. After installing GCC 6.3 and making it your default compiler, download bash and compile it from scratch: https://stackoverflow.com/questions/21644870/how-to-compile-bash

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.