0

I'm using the Xfce4 desktop environment on top of Linux Mint 18.1. When using Emacs in full-screen mode, I want to open a new application via the xfce whisker menu, but the new application is always hidden under the full-screen Emacs.

How can I make that new window gain the focus instead of full-screen Emacs?

  • Is the "New Window Focus" box checked in Settings -> Window Manager -> Focus? – Munir May 1 '17 at 15:28
  • @Munir: yes, it is checked. This problem happens to only the full-screen mode of Emacs, or other applications like Firefox, Google Chrome. – Trung Ta May 1 '17 at 15:41
  • 1
    Found another option that might cause this. In Settings -> Window Manager Tweaks -> Focus, uncheck "Activate focus stealing prevention". If it still doesn't work, maybe it's an Emacs thing. I don't use emacs so can't help much there. – Munir May 1 '17 at 15:56
  • Thanks a lot. It works perfectly. Do you want to create an answer so that I can upvote and accept it? :-D – Trung Ta May 1 '17 at 16:45
  • Added an answer now. – Munir May 1 '17 at 18:34
1

Go to Settings -> Window Manager -> Focus and check the box that says "New Window Focus"

Also, go to Settings -> Window Manager Tweaks -> Focus and uncheck the box that says "Activate focus stealing prevention"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.