3

let me preface my question by saying I'm completely new to Debian/Linux. Things are not going well in my first foray into Linux, and I'd appreciate any help!

I'm trying to install Debian 8 alongside my existing Windows 7. Here are the steps I've gone through so far:

  1. Downloaded "debian-8.7.1-amd64-CD-1.iso.torrent" from here and created a bootable USB flash drive using win32diskimager.

  2. Booted from the flash drive and used the Debian installer to repartition Windows--I gave Windows ~150GB of my 250GB SSD. I then let the Debian installer automatically configure the 80GB I had freed up. It created a 3.3GB swap partition and a ~75GB partition that I assume is for all things Debian.

  3. Went through the rest of the steps in the graphical installer e.g. choosing an account name and desktop environment; letting it install grub.

  4. When I finally finished and tried to boot up Debian for the first time, grub came up but only listed Debian and not Windows. Furthermore, when I select Debian, it hangs on a screen that says simply:

Loading, please wait...

/dev/sda5: clean, 104994/4685824 files, 1170977/18716672 blocks

I'm really not sure how to proceed from here. I did some searching and found suggestions to make sure legacy boot was enabled and fast boot was disabled, but found these were already the case when I checked my BIOS settings.

  • Welcome to U&L , reboot your system , when the grub menu appear , press e to edit grub then find ro quiet and change it to ro nomodeset quiet then press ctrl +x to boot – GAD3R May 1 '17 at 10:23
  • 1
    Thanks!!! That worked! It got me into Debian and from there I was able to update Grub and have Windows show up. – NewR May 4 '17 at 8:43
1

Reboot your system , when the grub menu appear , press e to edit grub. Then find ro quiet e,g:

linux   /vmlinuz-3.13-1-amd64 root=/dev/mapper/root-root init=/bin/systemd ro quiet

and change it to ro nomodeset quiet then press Ctrl +X to boot.

Open your nano /etc/default/grub then change the following line:

GRUB_CMDLINE_LINUX_DEFAULT="ro quiet"

to:

GRUB_CMDLINE_LINUX_DEFAULT="ro nomodeset quiet"

Save your file , exit and update Grub:

update-grub
2

High recommend that you grab the Stretch RC3 installer - It will be the new stable in a short time and is pretty much rock solid and my daily driver. It's available here including the firmware which is highly recommended for someone new to Linux in general, Debian specifically. https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/stretch_di_rc3/

Grab the one for your architecture obviously. Any further questions, just shout!

  • Have you tried it? You should feel good about installing the current or soon to be (no kidding) with up-to-date drivers/software. ( ͡° ͜ʖ ͡°) The current stable is over 2 years old. – SD Allen May 4 '17 at 16:56
  • This is probably going to be a disappointing response, but... I encountered so many hurdles after the one described above with Debian that I decided to switch to Linux Mint for my first foray into Linux. I think some but not all of them would have been solved by using the image with included firmware that you linked. – NewR May 9 '17 at 2:27
  • Unfortunate. Usually all one has to do to recover from the firmware issue is to enable the non-free archive via command line. But not a good way to treat newbies to Linux. That's the Debian way, they believe strongly in free software, and not many driver/firmware vendors will open their code for competitive reasons. I'd be careful with MINT though - It has a horrible attitude by the main developer(s) toward security and upgrades. Better to stick with the upstream which is Debian, if that sort of thing matters to you. – SD Allen May 10 '17 at 15:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.