1
linux-4tur:~ # ss -tulpn|grep LISTEN
...
tcp    LISTEN     0      50       :::1716                 :::*                   users:(("kdeconnectd",pid=3395,fd=12))
...
linux-4tur:~ # 
linux-4tur:~ # grep 1716 /etc/services 
xmsg               1716/tcp     # xmsg  [Mark_E_Fogle]
xmsg               1716/udp     # xmsg  [Mark_E_Fogle]
linux-4tur:~ # 
linux-4tur:~ # ps -ef|grep -i kdeconnectd|grep -v grep
user      3395  3384  0 10:07 ?        00:00:08 /usr/lib64/libexec/kdeconnectd
linux-4tur:~ # 

https://community.kde.org/KDEConnect#What_is_KDE_Connect.3F

I don't use this. But it listens on a port on all interfaces!

Q: How can I disable the kdeconnectd?

I tried to remove the kdeconnect-kde package, but if I do a "zypper up" after it, it reinstalls it, probably dependency..

I cannot see this as a separated service in systemctl. It is under "session-2.scope"

The binary is: /usr/lib64/libexec/kdeconnectd

1

You can exclude packages with this command:

sudo zypper addlock {package name}

So in your case it should look like this:

sudo zypper addlock kdeconnect-kde
  • first remove, then addlock, it worked! Thanks! – Peter May 1 '17 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.