1

When using Mint on Battery Power, if I connect my headphones in the headphones jack the system instantly crashes and shuts down. Although, this doesn't happen when I am using Mint in Charging Mode. Also, if the headphones are connected before system boot, Mint fails to recognize them and in order to use them, the headphones need to be reconnected when Mint is operating.

Here is my system info:

System:    Host: Felix-Mint Kernel: 4.4.0-53-generic x86_64 (64 bit gcc: 5.4.0)
       Desktop: Cinnamon 3.2.7 (Gtk 3.18.9-1ubuntu3.1)
       Distro: Linux Mint 18.1 Serena 
Machine:   System: Dell (portable) product: Inspiron 7560
       Mobo: Dell model: 07PJP0 v: A00
       Bios: Dell v: 1.0.8 date: 12/01/2016
CPU:       Dual core Intel Core i7-7500U (-HT-MCP-) cache: 4096 KB
       flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 11615
       clock speeds: max: 2701 MHz 1: 700 MHz 2: 1500 MHz 3: 600 MHz
       4: 600 MHz
Graphics:  Card-1: Intel Device 5916 bus-ID: 00:02.0
       Card-2: NVIDIA GM108M [GeForce 940MX] bus-ID: 01:00.0
       Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
       Resolution: 1920x1080@59.98hz
       GLX Renderer: Mesa DRI Intel Kabylake GT2
       GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio:     Card Intel Device 9d71 driver: snd_hda_intel bus-ID: 00:1f.3
       Sound: Advanced Linux Sound Architecture v: k4.4.0-53-generic

On going through my syslogs here is what I found:

Mar 14 18:19:01 Felix-Mint kernel: [  299.826425] mce: [Hardware Error]: Machine check events logged

And here is the mcelog:

mcelog: failed to prefill DIMM database from DMI data
mcelog: Family 6 Model 8e CPU: only decoding architectural errors
Hardware event. This is not a software error.
MCE 0
CPU 0 BANK 6 
MISC 43880018086 ADDR fef1ce80 
TIME 1489495442 Tue Mar 14 18:14:02 2017
MCG status:
MCi status:
Error overflow
Uncorrected error
MCi_MISC register valid
MCi_ADDR register valid
Processor context corrupt
MCA: corrected filtering (some unreported errors in same region)
Generic CACHE Level-2 Generic Error
STATUS ee2000000040110a MCGSTATUS 0
MCGCAP c08 APICID 0 SOCKETID 0 
CPUID Vendor Intel Family 6 Model 142
mcelog: Family 6 Model 8e CPU: only decoding architectural errors
Hardware event. This is not a software error.
MCE 1
CPU 0 BANK 7 
MISC 7880018086 ADDR fef1ce40 
TIME 1489495442 Tue Mar 14 18:14:02 2017
MCG status:
MCi status:
Error overflow
Uncorrected error
MCi_MISC register valid
MCi_ADDR register valid
Processor context corrupt
MCA: corrected filtering (some unreported errors in same region)
Generic CACHE Level-2 Generic Error
STATUS ee2000000040110a MCGSTATUS 0
MCGCAP c08 APICID 0 SOCKETID 0 
CPUID Vendor Intel Family 6 Model 142

Here are the syslogs when headphones are connected and working:

Apr 30 16:20:58 Felix-Mint kernel: [   16.819396] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
Apr 30 16:20:58 Felix-Mint kernel: [   16.819555] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
Apr 30 16:20:58 Felix-Mint kernel: [   16.845900] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
Apr 30 16:20:58 Felix-Mint kernel: [   16.909215] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC3246: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
Apr 30 16:20:58 Felix-Mint kernel: [   16.909217] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
Apr 30 16:20:58 Felix-Mint kernel: [   16.909217] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
Apr 30 16:20:58 Felix-Mint kernel: [   16.909218] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
Apr 30 16:20:58 Felix-Mint kernel: [   16.909218] snd_hda_codec_realtek hdaudioC0D0:    inputs:
Apr 30 16:20:58 Felix-Mint kernel: [   16.909219] snd_hda_codec_realtek hdaudioC0D0:      Headset Mic=0x19
Apr 30 16:20:58 Felix-Mint kernel: [   16.909220] snd_hda_codec_realtek hdaudioC0D0:      Headphone Mic=0x1a
Apr 30 16:20:58 Felix-Mint kernel: [   16.909221] snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x12
Apr 30 16:20:58 Felix-Mint kernel: [   17.139462] intel_rapl: Found RAPL domain package
Apr 30 16:20:58 Felix-Mint kernel: [   17.139464] intel_rapl: Found RAPL domain core
Apr 30 16:20:58 Felix-Mint kernel: [   17.139466] intel_rapl: Found RAPL domain uncore
Apr 30 16:20:58 Felix-Mint kernel: [   17.139468] intel_rapl: Found RAPL domain dram
Apr 30 16:20:58 Felix-Mint kernel: [   17.244470] dcdbas dcdbas: Dell Systems Management Base Driver (version 5.6.0-3.2)
Apr 30 16:20:58 Felix-Mint kernel: [   17.300464] input: HDA Intel PCH Headphone Mic as /devices/pci0000:00/0000:00:1f.3/sound/card0/input10
Apr 30 16:20:58 Felix-Mint kernel: [   17.300516] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input11
Apr 30 16:20:58 Felix-Mint kernel: [   17.300564] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input12
Apr 30 16:20:58 Felix-Mint kernel: [   17.300609] input: HDA Intel PCH HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input13
Apr 30 16:20:58 Felix-Mint kernel: [   17.437597] media: Linux media interface: v0.10
Apr 30 16:20:58 Felix-Mint kernel: [   17.462276] Linux video capture interface: v2.00

So, I am unable to decode and pinpoint the exact cause of this error, It is definitely caused due to the headphones being connected in Battery Mode causing this unexpected shutdown/halt. I also checked with 4.4 and 4.8 and 4.10, none of these Kernel versions have fixed the problem.

0

I shovelled the whole internet and found out that such problem (mce error) bothers unhappy owners of kabylake processors. I've got laptop Dell Vostro 15 5568 and have the same issue.

uname -a
Linux station 4.9.16-gentoo #55 SMP Thu May 4 21:52:33 MSK 2017 x86_64 Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz GenuineIntel GNU/Linux

My mcelog:

mcelog --cpu kabylake

Hardware event. This is not a software error.
MCE 0
CPU 0 BANK 6 
MISC 43880018086 ADDR fef1ce80 
TIME 1493934959 Fri May  5 00:55:59 2017
MCG status:
MCi status:
Error overflow
Uncorrected error
MCi_MISC register valid
MCi_ADDR register valid
Processor context corrupt
MCA: corrected filtering (some unreported errors in same region)
Generic CACHE Level-2 Generic Error
STATUS ee0000000040110a MCGSTATUS 0
MCGCAP c08 APICID 0 SOCKETID 0 
PPIN ee0000000040110a
CPUID Vendor Intel Family 6 Model 142
Hardware event. This is not a software error.
MCE 1
CPU 0 BANK 7 
MISC 7880018086 ADDR fef1ce40 
TIME 1493934959 Fri May  5 00:55:59 2017
MCG status:
MCi status:
Error overflow
Uncorrected error
MCi_MISC register valid
MCi_ADDR register valid
Processor context corrupt
MCA: corrected filtering (some unreported errors in same region)
Generic CACHE Level-2 Generic Error
STATUS ee0000000040110a MCGSTATUS 0
MCGCAP c08 APICID 0 SOCKETID 0 
CPUID Vendor Intel Family 6 Model 142

Internal keyboard sometimes freezes for a while when I watching video and during this I can move cursor using touchpad but cant click. Attached external usb mouse only helps. I had similar problem with connecting headphones to the laptop while the last one was using in battery power. This happens because our audio hardware can't turn to savepower mode properly. The only workaround I found here. You should change parameter INTEL_AUDIO_POWERSAVE to false in file /usr/lib/pm-utils/power.d/intel-audio-powersave.

I guess there is a relation with kabylake and hope they will check this soon and the issue will be resolved.

  • I have marked this answer as accepted, although after a reboot the issue still persists, it worked the first time but was not effective at all after the reboot and I am still facing abrupt crashes. – Shirish Kadam May 9 '17 at 18:36
0

So, disabling the power saving options in tlp seems to work for me. All TLP settings are stored in the config file /etc/default/tlp. The default configuration provides optimized power saving out of the box. Some advanced features like turning off the optical drive and battery thresholds need to be activated explicitly. Parameters ending on _BAT are effective when running on battery.

Disable the audio power saving mode. Timeout (in seconds) for the audio power saving mode (supports Intel HDA, AC97). A value of 0 disables power save.

SOUND_POWER_SAVE_ON_BAT=0

Then restart the tlp service : sudo service tlp restart

Source: http://linrunner.de/en/tlp/docs/tlp-configuration.html#audio

This should work with Ubuntu 14.04, 16.04 and 16.10; as well as Linux Mint 17 and 18.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.