1

I want to install an older version of selinux in order to install nvidia driver, dnf list shows there is an old package 3.13.1-225.11.fc25, how can I install that ?

I tried dnf install selinux-policy-3.13.1-225.11.fc25 , but it shows No package available

dnf downgrade selinux-policy --allowerasing works, but I can not control which version I want to downgrade to, and it actually downgrades to 3.13.1-224.fc25

Does the dark color mean it is not available? But it shows under Available Packages category.

dnf list

closed as unclear what you're asking by Jakuje, DarkHeart, Anthon, jimmij, Rui F Ribeiro May 1 '17 at 6:22

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • What is the output of dnf list --available selinux-policy? Also, is a downgrade of selinux-policy necessary for compatibility with the driver? – Fox Apr 30 '17 at 5:34
  • Also also, which version does it try if you run dnf --repo=updates --allowerasing downgrade selinux-policy? – Fox Apr 30 '17 at 5:38