0

I was working in Atom on a small webpage and suddendly it would not let me save my file, saying that read-only mode was turned on. I tried to update in the terminal but that would not let me either, so I rebooted hoping that would fix the issue. Instead I ran into more problems.

The first error was in the BIOS: HP error 501. I pressed enter to continue and this screen popped up:

Loading, please wait...
/dev/sda1: recovering journal
/dev/sda1 contains a file system with errors, check forced.
/dev/sda1:
Deleted inode 1048599 has zero dtime.  FIXED.
/dev/sda1: Inodes that were part of a corrupted orphan linked list found.

/dev/sda1: UNEXPECTED INCONSISTENCY:; RUN fsck MANUALLY
        (i.e., without -a or -p options)
fsck exited with status code 4
The root filesystem on /dev/sda1 requires a manual fsck
modprobe: module ehci-orion not found in modules.dep


BusyBox v1.22.1 (Debian 1:1.22.0-9+deb8u1) built-in shell (ash)
Enter 'help' for a list of built-in commands.

/bin/sh: can't access tty; job control turned off
(initramfs) _

Now I am stuck on the (initramfs) command prompt.

How can I get back to my system and files?

  • 1
    HP Error 501 appears to describe a corrupt or missing EFI system partition. Is this a new error? Have you been able to boot Linux without seeing this error before? If so, and judging from the output of fsck, you might have a failing hard drive. A quick search of HP Error 501 seems to note that disabling HP Quicklook in the BIOS tends to fix that error though, so that may not be the case – Fox Apr 30 '17 at 6:22
  • @Fox Yes this is the first time that this error popped up. So how would I reboot again to get into BIOS. Because I am stuck on the initramfs command and typing in reboot does nothing – dennievn Apr 30 '17 at 7:30
  • The (initramfs) prompt is an actual shell prompt. If reboot the command doesn't work, you might try init 6. Failing that, Alt+SysRq+REISUB is a key sequence to reboot in Linux, which might work here – Fox Apr 30 '17 at 7:37
  • @Fox so init 6 came up with "must be run as PID 1." Do you think I should just put in the bootable DVD? – dennievn Apr 30 '17 at 20:21
  • As a last attempt before that, you might try telinit 6, which is what init 6 would actually call. Though at this point, it doesn't seem that anything is mounted, and holding the power button is probably as reasonable as anything – Fox Apr 30 '17 at 20:24
2

Write fsck /dev/sdax (depends on the drive infected "sda1,sda2 etc") And then enter Then it will ask you many questions for editing just type Yes and after that restart it.

  • Why was this answer downvoted? It looks quite correct for me. (The option -y does the same as typing Yes for every question, which I would not recommend.) – user2233709 Oct 13 '17 at 8:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.