1

Since a few weeks, I get a notification after each boot telling me that important updates has been installed. Even if I dismiss it then immediately reboot, it comes again. It starts to be quite annoying.

It looks like it has started after I get a message asking me something like rebooting for installing updates (sorry, I do not remember precisely). I have done that, though not being used to it at all.

I am under Debian Jessie 8.7. My box is configured to run unattended upgrades, and it works fine since I have set it up. (That was when latest Jessie was 8.5.) It is shut down every day.

Is there any way to fix this?

1 Answer 1

3

Deleting the file

/var/lib/PackageKit/offline-update-competed

solves it.

Solution found on Debian forum here. It looks like it is a known bug.

But it seems to be there since at least two years. And so it may happen again eventually. I hope someone knows a better solution.

(And yes by the way, there is a typo in the file name.)

Follow-up: I am no more having this issue, but I am no more acting on updates notification nor select the "install update" option when shutting down. I just let unattended-upgrade do the job instead. It sounds to me as a reliable way to avoid the trouble.

1
  • 1
    nice catch, that one about the typo is priceless Apr 30, 2017 at 19:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .