5

I have some commands replaced with * in the bash history, e.g.

1094  apt-get update
1095* 
1096  dpkg -i /var/cache/apt/archives/libssl1.0.0_1.0.0h-1_amd64.deb

How to prevent this?

1

As explained in the Bash manual, history lines prefixed with a * have been modified. This happens when you navigate to a command (e.g. by using the Up key), edit it and then navigate away from it without hitting Enter. So a history line like this:

1095* 

is usually the result of navigating to a command in history, backspacing and navigating away from it. Knowing this, you can easily prevent such lines appearing in your Bash history.

BTW, you can revert modified commands to their unedited state by navigating to them and hitting Ctrl + _ repeatedly.

0

Looks like mark-modified-lines is enabled in your shell. Try disabling it in ~/.inputrc:

set mark-modified-lines Off

Details in man bash.

  • 3
    weird, bind -V | grep mark-modified-lines tells me it's set to off – Eugene Yarmash Apr 11 '12 at 12:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.