1

I have Windows 10 on SSD partition(1TB) and Linux Mint on Sata (1TB). But while booting, the system boots into Windows 10 only. I used supergrub disk and could see Mint Linux in the entries, which when clicked it boots into Mint. My questions are:

  1. Can I overwrite windows boot with mint ? If yes then how?

  2. Can I use supergrub to do this?

enter image description here

Can't see second hard disk

enter image description here

Can't even see second hard disk . How do I even boot into it then ? Changed SATA mode, still second hard disk not showing

1
  • please append the output of sudo ls /boot/efi and efibootmgr -v
    – Schives
    Apr 29, 2017 at 21:06

2 Answers 2

1

I don't really know but I think if you overwrite the Windows Boot Manager you can't boot in Windows anymore. But you can change in your UEFI/BIOS the default Hard Disk from which you boot. Now you boot in Linux Mint and type in the command:

sudo update-grub

Now somewhere should be a line which looks like this:

Found Windows [Version] (Loader) on /dev/{hard disk of the Windows Installation}

Now you can reboot your computer and see in the GRUB menu a entry to the Windows Boot Manager. If you choose it you should see your Windows booting.

2
  • Hmm that seems reasonable way. WIll try and update
    – vinita
    Apr 29, 2017 at 8:46
  • Cant even see second hard disk in BIOS . How do I even boot into it then ? Changed SATA mode, still second hard disk not showing. have added the pics, pls help
    – vinita
    Apr 29, 2017 at 14:10
1

I'm going to assume that because the windows disk has an EFI partition that you're booting with secure boot.

  1. make sure you installed grub in EFI mode - boot into mint, check for the EFI files: sudo su - cd /boot/efi ls If there is nothing there (or the directory doesn't exist), you have probably not mounted the EFI partition, so you're going to need to mount it (this also means you likely haven't installed in EFI mode).
    mkdir -p /boot/efi mount -t vfat /dev/sdXY /boot/efi where X is the drive letter as indexed by linux (not windows) and Y is the partition number of the EFI partition. You will also need to add this mount to /etc/fstab, but DO NOT use the /dev/sdXY path when appending to /etc/fstab, instead use blkid to get the UUID of the partition, so the entry should look like: UUID=1234-ABCD /boot/efi vfat umask=0077 0 1 if the partition has a UUID of 1234-ABCD (yours will almost certainly be different).

    If there is something there when you ls (there should at least be a directory named "Microsoft" - where the windows EFI files sit) but there is no other directory, you haven't installed grub in EFI mode, so: grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id="grub" --recheck --debug

  2. make sure the UEFI firmware accepted the boot entry (from mint, use efibootmgr -v to see the listings - and for your own good, I strongly suggest you read the manual). If there is no entry like "ubuntu", "grub", "linux", "debian", or the like, then you have no EFI entry for grub, so add it: efibootmgr -c -g -d /dev/sdX -p Y -w -L "grub" -l /EFI/grub/grubx64.efi where X is the drive letter as indexed by linux (not windows) and Y is the partition number of the EFI partition.

  3. make sure the UEFI firmware accepts either shim's or grub's EFI signature as valid and that it will boot to it when manually chosen
  4. go back into mint, disable the windows boot (do not remove it or windows, being the schizophrenic only child that it is, will write itself to the top of the list again) by using

    efibootmgr -b X -A where X is the number of the windows boot

    efibootmgr -o Z where Z is the number of the grub EFI entry

And finally, when all that's done, sudo update-grub, then reboot - if you did it right, you should have a grub boot screen with all the OSs available on the system in a list.

Other resources: Debian's article on UEFI and Archlinux's examples of grub with UEFI

2
  • Cant see second hard disk in bios. Have added pics, pls help
    – vinita
    Apr 29, 2017 at 14:11
  • updated with more detailed steps
    – Schives
    Apr 29, 2017 at 21:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .