1

On windows 7, I installed Cygwin, xorg-server, gnome-desktop, gnome-session.

I start X startxwin and the X server starts. I can run gedit and a gui of the gnome editor will start.

If i run gnome-session then, it gives this output:

$ gnome-session
gnome-session-binary: PID 8140: WARNING: Using null backend for session tracking
Unable to init server: Could not connect to 127.0.0.1: Connection refused

Any ideas how to start gnome?

  • are you setting DISPLAY in some way ? – matzeri Apr 29 '17 at 8:46
1

https://sourceware.org/ml/cygwin-announce/2015-10/msg00111.html

'-nolisten tcp' is now the default, so the server only accepts local connections on a unix domain socket. A '-listen' option has been added which can be used to restore the previous behaviour.

For connection to 127.0.0.1 you need to set -nolisten tcp, however currently the programs should not need it. May be something is requiring 127.0.0.1 for gnome-session like a old setting ?

$ echo $DISPLAY 
:0.0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.