I have followed all the instructions in the wiki page, I made:

sudo apt install libflashplayer-nonfree

But after the installation the folder /usr/lib/flashplugin-nonfree doesn't contain the library libflashplayer.so, there is only the pubkey.asc file. So Firefox can't see the plugin. I also have tried to find that library in other locations but it does not seem to be anywhere.

  • Was there an error reported when you ran update-flashplugin-nonfree --install? – Fox Apr 27 '17 at 22:20
  • I get the well known bug mentioned in the wiki: ERROR: wget failed to download http://people.debian.org/~bartm/flashplugin-nonfree/D5C0FC14/fp. – ceccoemi Apr 27 '17 at 22:26
  • Did you then use the manual work-around they suggest? If not, then you don't have the file because you didn't get the file – Fox Apr 27 '17 at 22:27
  • 1
    I believe the command is also run by the installation script, but if it had tried to run it would have encountered the same error as you saw post-install – Fox Apr 27 '17 at 22:32
  • 1
    Yes, that manual operation solved my problem. I thought that installing the package from apt would add the libflashplayer.so automatically. – ceccoemi Apr 28 '17 at 10:58

The file libflashplayer.so won't be installed because of the well known bug mentioned in the wiki in the manual update section. It seems that the command to update Flash Player update-flashplugin-nonfree --install is also executed by the installation script, so the library couldn't be downloaded. The solution for this problem was that one suggested in the wiki in the same section. I had to download the libflashplayer.so file from the Adobe site and copy it in /usr/lib/flashplugin-nonfree/.

  1. Get the file "flash_player_npapi_linux.x86_64.tar.gz" from "https://get.adobe.com/flashplayer/"
  2. Unpack the tar.gz file.
  3. Identify the location of the browser plugins directory, based on your Linux distribution and Firefox version: (e.g. /usr/lib/mozilla/plugins/)
  4. Copy libflashplayer.so to the appropriate browser plugins directory: sudo cp libflashlayer.so <BrowserPluginsLocation>
  5. Copy the Flash Player Local Settings configurations files to the /usr directory: sudo cp -r usr/* /usr
  6. Restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.