6

I'm new to Manjaro and AUR, having an almost same problem like this one on Ubuntu:

I have vagrant, virtualbox installed via pacman, then I try

$ vagrant up

VirtualBox is complaining that the kernel module is not loaded. Please run VBoxManage --version or open the VirtualBox GUI to see the error message which should contain instructions on how to fix this error.

$ VBoxManage --version

WARNING: The vboxdrv kernel module is not loaded. Either there is no module available for the current kernel (4.9.20-1-MANJARO) or it failed to load. Please recompile the kernel module and install it by

       sudo /sbin/vboxconfig

     You will not be able to start VMs until this problem is fixed.

5.1.20r114628

$ sudo /sbin/vboxconfig

sudo: /sbin/vboxconfig: command not found

According to the link I post, I try $ sudo /usr/lib/virtualbox/vboxdrv.sh setup

sudo: /usr/lib/virtualbox/vboxdrv.sh: command not found

I also find suggestion to modprobe vboxdrv:

$ modprobe vboxdrv

modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/4.9.20-1-MANJARO

$ dkms

Usage: /usr/bin/dkms [action] [options] [action] = { add | remove | build | install | uninstall | match | autoinstall | mkdriverdisk | mktarball | ldtarball | mkrpm | mkkmp | mkdeb | status } [options] = [-m module] [-v module-version] [-k kernel-version] [-a arch] [-d distro] [-c dkms.conf-location] [-q] [--force] [--all] [--templatekernel=kernel] [--directive='cli-directive=cli-value'] [--config=kernel-.config-location] [--archive=tarball-location] [--kernelsourcedir=source-location] [--no-prepare-kernel] [--no-initrd] [--binaries-only] [--source-only] [-r release (SuSE)] [--verbose] [--size] [--spec=specfile] [--media=floppy|iso|tar] [--legacy-postinst=0|1] [--no-depmod] [-j number] Error! No action was specified.

dkms seems alright?

How do I fix it?

  • Please show dkms status – user192526 Apr 27 '17 at 8:24
  • @Bahamut updated – Rahn Apr 27 '17 at 8:27
  • @Wentao you were asked for the dkms status and not for a plain dkms command; have you deployed development tools/gcc in that machine? – Rui F Ribeiro Apr 27 '17 at 8:44
  • @RuiFRibeiro $ dkms status prints nothing. gcc has been installed – Rahn Apr 27 '17 at 8:48
  • Check pacman or AUR for the virtualbox-dkms package, virtualbox host modules for ARCH specifically, – nannerpuss Apr 28 '17 at 6:18
3

You need to install

sudo pacman -S [kernel version]-virtualbox-host-modules

get kernel version: uname -r

Your user must be in the following groups

  • vboxusers for virtualbox to work
  • storage group (for the usb subsystem)
  • vboxsf group (to share files).
  • uucpgroup for serial port

To add a user to group vboxuser: gpasswd -a USERNAME vboxusers

Check the: manjaro wiki and archlinux wiki

  • $ sudo pacman -S virtualbox-host-modules-arch give me error: target not found: virtualbox-host-modules-arch – Rahn Apr 27 '17 at 9:38
  • sudo pacman -S linux37-virtualbox-host-modules with linux kernel 3.7. wiki.manjaro.org/index.php?title=VirtualBox#Install_VirtualBox – Michael D. Apr 27 '17 at 9:40
  • Yep, I've installed linux49-virtualbox-host-modules – Rahn Apr 27 '17 at 9:42
  • added user to vboxusers group? – Michael D. Apr 27 '17 at 9:44
  • 1
    It works ... for no reason after I reboot – Rahn Apr 27 '17 at 9:46
1

Rebooting my machine did the trick. This loaded the kernel modules for VirtualBox. I'm sure there is also a way to do this manually, but I didn't bother trying to figure it out when rebooting took less time.

0

I got the same error while starting a Windows7 VM on Arch for the first time after installing VirtualBox.

In my case running sudo modprobe vboxdrv gave no output (though there was no FATAL error as OP faced). Also sudo /sbin/vboxconfig command was not found.

Running rcvboxdrv seemed to do the trick:

$ sudo /sbin/rcvboxdrv
Unloading modules: vboxdrv 
Loading modules: vboxnetadp vboxnetflt vboxpci vboxdrv 

No reboot was required! The VM worked fine after that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.