2

We have 2 Amazon ec2 AMI linux instances (2017.03) that have mounts pointing back to different windows servers in our office and other locations using cifs. These mounts have been up for about 2 months with no issues until about 2 or 3 days ago. Now we are getting intermittent connectivity issues.

For example, sometimes when I do:

ls /mnt/qdrive 

it works, but sometimes I get:

ls: cannot access /mnt/qdrive: Host is down

If I wait a few seconds and try again, it works. I have tried having 1 putty window open that is pinging the server and in another running the ls command and the ping comes back with data every time, but I get the Host is down error.

I also tried restarting the smb service, but it didn't seem to matter.

What would cause this type of intermittent connectivity? Is there anything I can do to fix it?

  • Pinging the external host doesn't necessarily say that the CIFS service isn't having issues. Can you see anything in /var/log/messages that might indicate an issue with CIFS? When it is mounted whats in /proc/fs/cifs/DebugData ? – LV426 Apr 26 '17 at 12:47
  • This is what's in the DebugData log for one of the servers: pastebin.com/ppmzDqFt – raphael75 Apr 26 '17 at 12:57
  • I discovered that I can use the smbclient command line and it seems to have no connectivity issues. I'm not sure how it differs in how it connects from how the mount command does it. – raphael75 Apr 27 '17 at 11:17
  • Another bit of information - I found out from our networking team that our virtual Sophos on aws was having issues with many other connections, and we restarted it. It seems that has fixed most, if not all, of our connectivity issues. – raphael75 Apr 28 '17 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.