0

I have a box with gigabyte GA-B150-HD3 motherboard, I installed Centos 7 on its SSD and every thing worked fine. But for some reason I have to install Centos 5 on it and I installed Centos 5.11 on it. during the installation process my mouse wasn't working and after installation non of usb drives works and only my ps2 keyboard is working(even my ps2 mouse is not working). Following suggestions on this thread usb device not working I enabled "xHCI handoff" (I don't have iommu option in bios!!) on bios and tried iommu=on , iommu=soft and iommu=pt kernel options, none worked.

lsusb command shows nothing. and this is output of lsmod command before and after loading usb_storage: enter image description here

this is output for dmesg: enter image description here

any help on how to fix the problem?

Edit: this is my kernel options in grub.conf:

kernel /vmlinuz-2.6.18-398.el5 ro root=/dev/VolGroup/LogVol00 noapic acpi=off rhgb
2

GA-B150-HD3 is a fairly recent motherboard, much more recent than CentOS 5's kernel 2.6.18. You don't have drivers for hardware that didn't even exist when the kernel was released. You need a newer kernel.

Elrepo carries kernel backports for CentOS, but I think they no longer support CentOS 5.

My recommendation would be to install a recent distribution, such as CentOS 7, and run whatever you need on CentOS 5 in a virtual environment. This doesn't have to be a full-fledged virtual machine if you can't take the performance hit, a simple chroot is enough for many things, and if it doesn't work you may use namespaces or containers — run the userland of CentOS 5 on a CentOS 7 kernel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.