0

I am working on an embedded system built around Atmel ARM926EJ-S based on rather old ARM core ARMv5TEJ. I have a Debian 8 system that used to work for that hardware until I had to update the kernel from 3.11.6 to 4.1.18. The update was needed in order to add support for certain USB hardware.

The update gave me what I wanted with one exception: reboot is not working anymore. More precisely put, when I write command reboot into console, the system shuts itself down, but in the end, instead of actually rebooting the CPU, it just halts, requiring use of the power switch to get the system up again.

What could cause this? Are there any typical issues that I could check?

Here are the last lines of the debug console:

systemd-shutdown[1]: Sending SIGTERM to remaining processes...
systemd-journald[721]: Received SIGTERM from PID 1 (systemd-shutdow).
systemd-shutdown[1]: Sending SIGKILL to remaining processes...
systemd-shutdown[1]: Unmounting file systems.
systemd-shutdown[1]: Unmounting /sys/kernel/debug.
EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
systemd-shutdown[1]: All filesystems unmounted.
systemd-shutdown[1]: Deactivating swaps.
systemd-shutdown[1]: All swaps deactivated.
systemd-shutdown[1]: Detaching loop devices.
systemd-shutdown[1]: All loop devices detached.
systemd-shutdown[1]: Detaching DM devices.
systemd-shutdown[1]: All DM devices detached.
systemd-shutdown[1]: Rebooting.
reboot: Restarting system
Reboot failed -- System halted
  • Does regular shutdown -r now work? Or even better, since it's Debian8: systemctl reboot – NarūnasK Apr 26 '17 at 8:25
  • They both did exactly the same as reboot. I added the debug console output to the question. – TheAG Apr 26 '17 at 8:38
  • In the PC arch, this is normally solved by ACPI, no idea about ATMEL. – Rui F Ribeiro Apr 26 '17 at 8:44
  • Apparently implementation of the watchdog in the new kernel has changed. Try to modify your /etc/systemd/system.conf and set ShutdownWatchdogSec=1. – NarūnasK Apr 26 '17 at 8:48
  • I tried that but it didn't change anything. – TheAG Apr 26 '17 at 8:55
0

I tried kernel version 4.11.0 which is the latest stable version at the moment, as suggested in the comments to the question. There were some new options regarding reboot and it works now.

I didn't investigate the details further so I can't tell whether something had been broken and then got fixed again or if version 4.1.18 could have been fixed with proper configuration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.