0

I am trying to setup a iSCSI envrionment on Xubuntu with iSCSI Enterprise Target. I choose this impelmentation because I need the iSCSI redirection feature.

First, I installed below 2 pacakges:

enter image description here

Then I tried to start the servie ietd and check the status of the service :

sudo service iscsitarget start sudo service iscsitarget status

It shows the iscsitarget service is exited. It looks strange but I don't know why. enter image description here

Since service is not working, I tried to run the ietd as foreground with -f switch. The -c switch is to specify the config file.

sudo ietd -f -c /etc/iet/ietd.conf

It shows this error: enter image description here

So I guess some kernel module is missing. If so, how can I fix it? I thought the kernel module is already installed with the iscsitarget-dkms pacakge.

2
  • Do you find any clue in /proc/modules about the module is actually installed? – Zumo de Vidrio Apr 25 '17 at 7:26
  • @ZumodeVidrio I just checked, there's no clue of iet in the modules file. But why it mentioned the proc/devices file? – smwikipedia Apr 25 '17 at 7:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.