3

We have 2 linux RH servers, that were configured the same way. Same OS version, same ftp client, etc.

The ftp client that we had installed is located in this website.

http://rpm.pbone.net/index.php3/stat/4/idpl/20810117/dir/scientific_linux_6/com/ftp-0.17-53.el6.x86_64.rpm.html

The permissions were already set up equally at a firewall level, for both servers. Both are on the same vlan 10.240.194.x/23

We have server A and B.

Server A connects to the ftp server withouth issues, we just have to set it up in active connection.

Server B does connect as well and we set it up in active mode. But when we try to list files/directories, find current dir location, or upload/download files we can't. So far the only thing we are able to do, is change to another directory.

Everytime we try, to do at least a simple ls,pwd we get this msg

200 PORT command successful.
150 Opening ASCII mode data connection.    #It gets stuck here for a while. 
500 Command not understood. 

As far as I understand, that ftp client, which is installed in both servers, doesn't have anything to be changed or configured.

Does anyone has an idea of what could be check/change to make the other server work. Sadly the FTP server, is not owned by our company. I tried to do some search, but haven't been lucky.

Any help is appreciated.

  • 2
    Is there a particular reason that you're setting up an FTP server in 2017? It's almost, but not quite, as outmoded a server infrastructure as telnet. – DopeGhoti Apr 24 '17 at 21:21
  • The client decided to receive the files from the Linux server, through FTP. So it wasn't up to us, neither the ftp server is from us – cees09 Apr 24 '17 at 21:39
3

You have to do FTP in passive mode and not active mode.

If using a text client, you have to use the command:

PASV

If using another piece of software, you will have to find the menu for PASSIVE mode transmission.

see Active FTP vs. Passive FTP, a Definitive Explanation

1

Possible problem with SELinux. Run the setsebool -P ftp_home_dir on command as the root user to enable access to FTP home directories.

See https://www.certdepot.net/selinux-use-boolean-settings/

  • damned, the thing is that in order to disable it, we need to restart the server. Since its a production server that is 24x7 used, restarting can't be done, unless this is truly the problem or the server hangs completely. I find out that in the server that the ftp works, this SeLinux is disabled.... – cees09 Apr 24 '17 at 22:00
  • 1
    You can run setsebool without rebooting the server. – fpmurphy Apr 25 '17 at 0:42
  • did as you said, still problem is not resolve. The server connects to the ftp as always but as soon as I do a ls or pwd, it stucks for a while with the message " 150 Opening ASCII mode data connection." and then displays "ftp: accept: Resource temporarily unavailable 550 500 Command not understood. " which is not true about the resource temporarily unavaiable, as the ftp is working fine and the other Linux server can connect and send files. – cees09 Apr 26 '17 at 19:54
  • Make sure the directory has read and execute permissions for the user you are trying to log in as. Try chmod a+rx directory. Can you do a ls -l one level up from the directory you are trying to access? – Robert Jacobs Apr 27 '17 at 13:04
  • You might want to restart the ftp server after trying the setbool command. – Robert Jacobs Apr 27 '17 at 13:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.