0

Disclaimer:

This really is not a major issue critical to the stable operation of my system but I am asking this because I simply can't make any sense of it and I would really like to know what is going on here.


I am running an arch linux box and just did yaourt -Syua. Everything went fine. I did a reboot and checked systemctl list-units --state failed to see ntpd.service as a result. I journalctl -r -u ntpd and found the entry

Apr 24 19:54:33 htpc ntpd[1850]: /usr/bin/ntpd: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory

Running ldconfig -v | grep libcrypto yielded

libcrypto.so.1.1 -> libcrypto.so.1.1

Which in turn belongs to openssl

# yaourt -Ql | grep libcrypto
openssl /usr/lib/libcrypto.so
openssl /usr/lib/libcrypto.so.1.1

I then thought maybe something didn't upgrade the first time I ran yaourt -Syua so I tried a second time with no upgrade candidates. And the most likely candidate would be ntp anyway given that openssl was upgraded successfully

# yaourt -Si openssl | grep Version && yaourt -Qi openssl | grep Version
Version         : 1.1.0.e-1
Version         : 1.1.0.e-1

Checking ntpversion

# yaourt -Si ntp | grep Version && yaourt -Qi ntp | grep Version
Version         : 4.2.8.p9-2   // in the offical `Extra` repo
Version         : 4.2.8.p10-1  // installed on my system??

Just to see what would happen I tried to (re-)install ntp

# yaourt -Sy ntp
:: Synchronising package databases...
core is up to date
extra is up to date
archlinuxfr is up to date
community is up to date
multilib is up to date
warning: downgrading package ntp (4.2.8.p10-1 => 4.2.8.p9-2)
Packages (1) ntp-4.2.8.p9-2

Total Download Size:    1.71 MiB
Total Installed Size:   4.09 MiB
Net Upgrade Size:      -0.10 MiB

:: Proceed with installation? [Y/n]

This then completely flustered me. It wants me to downgrade ntp when I just upgraded openssl in order to use the correct libcrypto.so?

# cat /var/log/pacman.log | grep openssl
[2017-04-24 19:23] [ALPM] upgraded openssl (1.0.2.k-1 -> 1.1.0.e-1)

# cat /var/log/pacman.log | grep ntp
[2017-04-13 18:08] [ALPM] upgraded ntp (4.2.8.p9-1 -> 4.2.8.p10-1)

Also when looking at the official Arch Linux site, it says for the ntppackage its outdated stating ntp 4.2.8.p9-2 as the current version.

My Questions

  • How is it possible that I have a newer ntpversion than stated in the official Extra repository while I only have one other custom repository ([archlinuxfr] - for yaourt) that does not carry ntp? I checked.
  • Why is yaourt/pacman suggesting me to downgrade my package?
  • Will downgrading my package actually solve my ntp problem or should I rather downgrade openssl assuming there to be the right libcrypto.so version?

Edit 1

I have a second arch linux box I also upgraded today where I dont have the issue. Here are the two pacman.log's in comparison. Might shed also some light on this:

BoxRunningFine# cat /var/log/pacman.log | grep -e "upgraded openssl" -e "upgraded ntp"
[2017-01-04 21:26] [ALPM] upgraded ntp (4.2.8.p8-1 -> 4.2.8.p9-1)
[2017-02-28 19:05] [ALPM] upgraded openssl (1.0.2.j-1 -> 1.0.2.k-1)
[2017-04-24 18:48] [ALPM] upgraded openssl (1.0.2.k-1 -> 1.1.0.e-1)
[2017-04-24 18:49] [ALPM] upgraded ntp (4.2.8.p9-1 -> 4.2.8.p9-2)


BoxWithIssue# cat /var/log/pacman.log | grep -e "upgraded ntp" -e "upgraded openssl"
[2016-06-05 03:18] [ALPM] upgraded ntp (4.2.8.p7-1 -> 4.2.8.p8-1)
[2016-10-21 18:17] [ALPM] upgraded openssl (1.0.2.h-1 -> 1.0.2.j-1)
[2017-01-06 14:18] [ALPM] upgraded ntp (4.2.8.p8-1 -> 4.2.8.p9-1)
[2017-02-08 22:54] [ALPM] upgraded openssl (1.0.2.j-1 -> 1.0.2.k-1)
[2017-04-13 18:08] [ALPM] upgraded ntp (4.2.8.p9-1 -> 4.2.8.p10-1)
[2017-04-24 19:23] [ALPM] upgraded openssl (1.0.2.k-1 -> 1.1.0.e-1)

By the looks of it the upgrading timing on the box with the issues was just poor. Guess that would be a classic case of bad luck. So then I just downgrade to 4.2.8.p9-2 and it should be fine I reckon?

Edit 2

# yaourt -Sy ntp
warning: downgrading package ntp (4.2.8.p10-1 => 4.2.8.p9-2)
Packages (1) ntp-4.2.8.p9-2
:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 ntp-4.2.8.p9-2-x86_64
(1/1) downgrading ntp                             

# systemctl start ntpd && systemctl status ntpd
● ntpd.service - Network Time Service
   Loaded: loaded (/usr/lib/systemd/system/ntpd.service; enabled; vendor preset: disabled)
   Active: active (running) since Mon 2017-04-24 21:14:41 CEST; 5s ago

# yaourt -Qi ntp
Name            : ntp
Version         : 4.2.8.p9-2

# systemctl status | grep -m1 State:
State: running

Problem solved. Downgrading to ntp-4.2.8.p9-2 was the solution. Thanks for the help and providing the according resources.

1 Answer 1

0

This looks like this bug which reads:

4.2.8.p10-1 has been replaced with 4.2.8.p9-2 apparently by the openssl rebuild.

I assume that the rebuild for the OpenSSL update was in staging long enough to be superseded in the meantime by the update for a new upstream release, but then when the OpenSSL rebuild was moved from staging to community, the package with the lower version number replaced the one with the higher one.

Edit: It looks like 4.2.8.p10-2 has already been uploaded to correct this situation.

2
  • That makes sense. I also overlooked the difference in the versions from p9-1 to p9-2. In light of those circumstances the downgrade should resolve this issue since I am not downgrading to my previous ntpversion but the p9-2. I'll give it a try and report the outcome.
    – Sven M.
    Apr 24, 2017 at 19:13
  • While I was downgrading to p9-2 they actually brought up the fix to p10-2? Well I guess time for a second round of updating/upgrading - then again the mirrors probably have to catch up syncing -. Thanks for status update as the package version changed during the course of this troubleshooting session.
    – Sven M.
    Apr 24, 2017 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.