3

Problem:

GNome terminal repeats key press, like it was stuck or I am holding the key in.

e.g. I would type:

hello

then a second later this would happen:

hellooooooooooooooooooooo -continue forever

then if I press enter or any other key e.g. s, that key will repeat:

hellooooooooooooooooooooossssssssssssssssss -continue forever


Solution (temporary):

To stop this repeated key press, there are 2 solutions:

  1. Close window

    • lose everything in window, i.e. working on an unsaved script in nano - everything gets lost
  2. Alt + Tab

    • Alt + Tab to another window I found is the best solution, this cancels the repeat operation,

of which the cause is still unknown


More Info:

Note: the solution specified by set r off referred to here is not the same issue.

  • Setting xset r off prevents me from holding backspace in to backspace several characters, this requires me to press backspace for each character

It seems like this is an old issue started back i 2007

I have found this issue to be at random and occur frequently within the Gnome terminal, possibly other applications too (to be confirmed)

Other applications include:

  • Gedit
  • IdeaC IntelliJ

Note:

Another post suggested to go to System->Preferences->Keyboard and turn off / uncheck "Repeat Keys"

however this Repeat keys option or System menu is not present, only Settings > Keyboard presents me with Keyboard shortcuts only.

System Info:

  • Arch - 4.10.11-1-ARCH Gnome-shell
  • GNOME Shell - 3.22.3 Gnome-terminal
  • GNOME Terminal - 3.22.1 Using VTE version 0.46.1 +GNUTLS

Are there any real solutions for this issue?

UPDATE

Thanks to @user2456699 who presented his problem and findings, followed by my own testing:

confirming results found,

Pressing Fn continuously and right before stopping, press one of the arrow keys

e.g Fn, Fn, Fn, Fn, ... , Fn + Down (Page Down)

this continuously scrolls down. Pressing any other key will inherit this repetition, until, as mentioned above, Alt + Tab to another window.

0

Yeah, this is still bothering me. The problem seems to be caused by the interaction between Xorg and my keyboard firmware.

The problem happens when an e.g. left/right arrow key is held down, then the FN key is held down, then the arrow key is released, then the FN key is released. My X11 system does not recognize that the initial arrow key is ever released, and instead assumes that the FN+key combination (Home or End keys, on my keyboard) is released.

Then X11 assumes the e.g. arrow key is still pressed, and continues to submit keypress/keyrelease events for it.

As mentioned,this can be avoided by turning off key repeats. For me, on Debian Stretch + Gnome 3.22.2, I can go to Settings->Universal Access->Typing and turn off "Repeat Keys". This seems to be functionally the same as using xset r off, and is a mildly inconvenient solution since it it disables the functionality of holding a key down.

  • Note that I encounter this issue with GNOME under Wayland also, sometimes. (not with the terminal, however) Also note that you can of course also just increase the "repeat key" delay with a slider under the location you mentioned, which should also mitigate that problem. – rugk Oct 23 '18 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.