0

I'm testing some custom kernels. But each time I rebuild the bzImage and copy it to /boot directory, it refuses to boot and stuck at initramfs.

I recognised the problem as previously built kernel modules are not loading with the new kernel.

disagrees about version of symbol module_layout

As they're looking for the exactly same kernel version.

I don't want to rebuild the modules each time.

So is there any way to force the kernel not to check kernel version, like --force-varmagic and load them ?

Also is there any way to disable this local version related issue while configuring the kernel ?

Updates

  1. In my kernel configuration CONFIG_MODVERSIONS is y and CONFIG_MODULE_FORCE_LOAD is also y .
  • Please do not delete a question and then ask the exact same question again. This is just annoying and serves no good purpose other than trolling. – Julie Pelletier Apr 24 '17 at 14:53
  • @JuliePelletier, and please let me know exactly how it happened ? I never deleted a question, just edited it after publishing. – Arnab Apr 25 '17 at 5:21
  • Sorry if my memory played tricks on me. Weird! – Julie Pelletier Apr 25 '17 at 5:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.