-1

I just created a USB bootable for ubuntu (but also tried other distrib) but I did not succeed to go on it since GRUB display this:

error: unknow filesystem
Entering rescue mode...
grub rescue> ls
(hd0)(hd1)

I have a XPS 13 (9360) and I don't know how to fix this problem... I tried some solutions proposed over the web but it did not works for me.

Resume: I put ubuntu (version 17.04) on an USB flash drive for boot on it and install ubuntu but I can't since GRUB (from the USB flash drive) give me this error. I tried this for example but it failed every time after insmod normal.

PS: I switch the SATA mode from RAID to AHCI but I don't think it's related since booting on the USB flash drive should not depend on my SSD.

  • 1
    Did you try the steps described at askubuntu.com/questions/119597/… ? – Julie Pelletier Apr 23 '17 at 14:35
  • Yes, it did not work for me. I have not the same output, ex I see (hd0)(hd1) and not (hdX,Y) – mykiwi Apr 23 '17 at 15:06
  • That seems to show that you didn't partition the drive, which apparently doesn't prevent grub from loading, therefore it could be bootable. – Julie Pelletier Apr 23 '17 at 15:11
  • Yes. But each time I try insmod ... I get error: no such partition – mykiwi Apr 23 '17 at 15:20
  • I think this can be solved but your best bet is probably to partition the drive properly and reinstall. – Julie Pelletier Apr 24 '17 at 2:57
0

I think you may use Boot Repair to Repair you grub .and when you Log On the Boot Repair system you may use fdisk -l to lookup you Hard Disk . and with worst-case is mean you must backup your file and reinstall the system

  • I don't have grub installed yet... It's the one from my USB flash drive for run the live CD. – mykiwi Apr 24 '17 at 8:24
  • so i think you may reform ubnutu live cd, this maybe about ubuntu ISO md5 , redownload and check the iso md5 right – zore lu Apr 25 '17 at 3:43
-1

To bypass this problem, here it's what I did:

  • use rufus
  • choose "MBR partition schema for UEFI"
  • write in DD image mode
  • This does not answer your own question. It shows one of multiple ways to properly write a bootable USB drive but it doesn't show how to fix your issue. This makes the question completely useless. – Julie Pelletier Apr 26 '17 at 2:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.