3

I was able to create an adhoc access point on my debian (raspberry pi) but when searching for wifi it shows the access point as a different symbol (ad hoc) and when I disconnect from it the access point shuts down. How do I prevent it from shutting down or used another mode? Below is most of my /etc/network/interfaces (the other lines are for wlan1)

auto wlan0
iface wlan0 inet static
    address 10.0.0.1
    netmask 255.255.255.0
    wireless-channel 1
    wireless-essid MYNETWORK
    wireless-mode ad-hoc
4

The point is, it is creating an wireless adhoc access point because you are asking it to create an adhoc access point.

You need to create an AP in BSS (infrastructure mode) with hostapd.

see: Setting up a wireless-to-wireless router

and

Setting up an access point

The hostap package implements the wifi AP functionality to wifi clients connect to you in a way similar to what most commercial wifi access points give you; in fact many/some commercial APs use it.

Be aware that the quality of your wifi brand also affects the experience. The internal wifi adapter may need an external antena, the official wifi rpi adapters (mediatek?) are nothing out of ordinary, they are nano adapters have a (very) short range due to their internal wifi antena being short.

I recommend a ralink USB wifi stick or a more expensive atheros. See Wi-Fi problems using ASUS USB-N13 adapter

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy