4

I want to remove the functionality of Alt+F1 in Gnome Shell. I've tried poking around gconf-editor and dconf-editor, as well as the normal Keyboard settings (super → "keyboard" → click Keyboard), but couldn't find anything. I also wasn't able to find anything when I searched on Google. How can I do this?

3
  • Please accept an answer (with the green tick button) rather than putting "resolved" in the title. May 26, 2017 at 18:05
  • @Nero gris: Philip Kendall is right: on Stack Exchange, we don’t put answers into questions.  If don_crissti’s answer solved your problem, you should “accept” it by clicking on the checkmark to the left.  Otherwise, answer your own question (click on “Answer Your Question”) and describe your resolution.  (If you can identify the specific update to Gnome that did the trick, that would be great.)  You should then accept your answer.  Since you are a new user with a low reputation score, you may need to wait a few hours (or even days?) before the system will allow you to accept your own answer. May 26, 2017 at 18:54
  • Ah. Got it. Since the "solution" was essentially "wait for upsteam to 'fix' it", I didn't think that warrented it's own answer, but I'll do that.
    – Nero gris
    May 27, 2017 at 18:53

3 Answers 3

4

In Gnome 41, I also had to do

gsettings set org.gnome.shell.extensions.apps-menu apps-menu-toggle-menu "[]"

(or you can modify the key using the dconf-editor UI)

3

That's one of the wm keybindings - you can change it via dconf-editor if you navigate to
org / gnome / desktop / wm / keybindings:

enter image description here

and select/click on panel-main-menu:

enter image description here


You can also do that in CLI via dconf or gsettings e.g.

To get the current keybindings:

gsettings get org.gnome.desktop.wm.keybindings panel-main-menu
['<Super>s', '<Alt>F1']

To set different keybindings use the same syntax - it's an array of quoted strings, separated by a comma and a space, everything enclosed in double quotes:

gsettings set org.gnome.desktop.wm.keybindings panel-main-menu "['<Super>s']"
2
  • That's really weird. I went to that spot in dconf-editor, but the "panel-main-menu" entry only had Super listed. Alt+F1 wasn't there, like it is in your screenshot.
    – Nero gris
    Apr 23, 2017 at 17:49
  • @Nerogris - not sure what your gnome version is but the <ALT>F1 combo has been there for at least four years now... Apr 23, 2017 at 19:40
2

Not much of an answer, but I was told that posting the answer in the question post is unacceptable.

Pretty much the solution was "it started working as expected". That is to say the "super → "keyboard" → click Keyboard"" thing I tried before, which failed due to the required option being absent previously, succeeded because the required option was now present.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .