2

i just started using linux and i've been trying to setup my old Belkin Wireless G USB Network Adapter with no luck. The system detects the device and Network Manager shows the option to turn wifi on/off but it can't find any networks even with 'iwlist DEVICE scanning' (shows no scan results).. Already tried installing the rt2500usb drivers with ndiswrapper but still the same result.

It would be great if someone could help me out. Thanks

This is what i have:

System:    Host: HWNLINUX Kernel: 4.4.0-53-generic i686 (32 bit) Desktop: Xfce 4.12.3
           Distro: Linux Mint 18.1 Serena
Machine:   Mobo: TAR model: P4M89-M7B v: Ver:1.0 Bios: Phoenix v: 6.00 PG date: 08/02/2007
CPU:       Dual core Intel Pentium Dual E2140 (-MCP-) cache: 1024 KB 
           clock speeds: max: 800 MHz 1: 800 MHz 2: 600 MHz
Graphics:  Card: VIA P4M890 [S3 UniChrome Pro]
           Display Server: X.Org 1.18.4 drivers: fbdev (unloaded: vesa) Resolution: 1280x1024@77.00hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.8, 128 bits) GLX Version: 3.0 Mesa 11.2.0
Audio:     Card VIA VT8237A/VT8251 HDA Controller driver: snd_hda_intel Sound: ALSA v: k4.4.0-53-generic
Network:   Card-1: VIA VT6102/VT6103 [Rhine-II] driver: via-rhine
           IF: enp0s18 state: unknown speed: 100 Mbps duplex: full mac: 00:e0:4d:4e:9e:cb
           Card-2: Belkin F5D7050 Wireless G Adapter v1000/v2000 [Intersil ISL3887]
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 250.1GB (2.9% used) ID-1: /dev/sda model: SAMSUNG_HD250HJ size: 250.1GB
Partition: ID-1: / size: 228G used: 5.0G (3%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 2.08GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 48.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 183 Uptime: 29 min Memory: 580.7/1948.8MB Client: Shell (bash) inxi: 2.2.35 

iwconfig:

wlx0011508a31ab  IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

lo        no wireless extensions.

enp0s18   no wireless extensions.

sudo lshw -C network:

  *-usb                   
       description: Wireless interface
       product: Belkin 54g USB Network Adapter
       vendor: Belkin
       physical id: 4
       bus info: usb@1:4
       logical name: wlx0011508a31ab
       version: 0.01
       serial: 00:11:50:8a:31:ab
       capabilities: usb-2.00 ethernet physical wireless
       configuration: broadcast=yes driver=rt2500usb driverversion=4.4.0-53-generic firmware=N/A link=no maxpower=300mA multicast=yes speed=480Mbit/s wireless=IEEE 802.11bg
  *-network
       description: Ethernet interface
       product: VT6102/VT6103 [Rhine-II]
       vendor: VIA Technologies, Inc.
       physical id: 12
       bus info: pci@0000:00:12.0
       logical name: enp0s18
       version: 7c
       serial: 00:e0:4d:4e:9e:cb
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=via-rhine driverversion=1.5.1 duplex=full ip=192.168.0.104 latency=32 link=yes maxlatency=8 mingnt=3 multicast=yes port=MII speed=100Mbit/s
       resources: irq:23 ioport:d000(size=256) memory:fdffe000-fdffe0ff

lsusb:

Bus 001 Device 002: ID 050d:7050 Belkin Components F5D7050 Wireless G Adapter v1000/v2000 [Intersil ISL3887]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

lsmod | grep rt2500usb:

rt2500usb              32768  0
rt2x00usb              20480  1 rt2500usb
rt2x00lib              49152  2 rt2x00usb,rt2500usb
  • The rt2500usb is introduced on the kernel linux , First , verify if the module is loaded lsmod | grep rt2500usb . to load the module modprobe rt2500usb – GAD3R Apr 22 '17 at 11:26
  • Please edit to include results for lsusb – Jeremy31 Apr 22 '17 at 13:05
  • 1
    Sorry, i didn't get an email notifying me about the comments.. i edited the post to include the result of lsmod | grep rt2500usb and lsusb commands. I tried loading the modules but nothing happened – Carlos Urdaneta Apr 23 '17 at 0:04
  • @CarlosUrdaneta install the firmware-ralink package then try to scan sudo iwlist scanning | grep SSID – GAD3R Apr 23 '17 at 11:46
  • @GAD3R it throws an error trying to install the firmware: <br/> dpkg: error processing archive /var/cache/apt/archives/firmware-ralink_0.43_all.deb (--unpack): trying to overwrite '/lib/firmware/rt3290.bin', which is also in package linux-firmware 1.157.5 <br/> does this means that it's already installed? – Carlos Urdaneta Apr 23 '17 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.