I recently had trouble with my trackpad mouse clicks not registering in Ubuntu. I tried a known good wireless mouse(It works on my windows machine) to no avail, I then looked around on the internet for a while and didn't find any fixes. So I decided to backup my data and do a fresh install of Ubuntu assuming it was just something that went wrong with the OS or something. I made it to the first screen where it asks you to select a language and neither my trackpad nor my wireless mouse could click on anything.

I happened to have a Kali Linux live usb laying around so I tried that and poof everything was working as it should. I then decided to try other Ubuntu variants to see if it was just an Ubuntu issue. I tried Kubuntu as well as Xubuntu and had the same issue as I had in Ubuntu. I then decided to try Fedora to see if the issue would arise there. Nope.

I'm completely at a loss, I have no clue what issue could exist in Ubuntu and its variants that doesn't exist in other Linux distros. This is especially confusing given that this started happening after I dropped my laptop which I assumed meant it was a hardware issue and that something had physically broken inside the trackpad.

Any ideas as to what the problem might be?

closed as unclear what you're asking by Gilles, GAD3R, Rui F Ribeiro, DarkHeart, Archemar Apr 24 '17 at 9:53

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Please edit your question and add some information about your hardware. Especially your trackpad. – terdon Apr 21 '17 at 21:41
  • 1
    If it doesn't work on a particular version of Ubuntu but works on other distributions (Kubuntu and Xubuntu are the same distribution as Ubuntu, just with different default settings), then the problem is probably a bug in the particular version of the driver in this version of Ubuntu. Other distributions work because they have an older or newer version of the driver that doesn't have the bug. Try a backport kernel. – Gilles Apr 22 '17 at 20:46

So as I was working my way through different Linux distros, I started noticing the issue popping up in distros unrelated to Ubuntu and I've come to the conclusion that something is just broken internally. Thanks for all the replies

Not the answer you're looking for? Browse other questions tagged or ask your own question.