I use a wired PPPoE connection to connect to the Internet. What I need to do on Windows to connect to it is put in static IP address, gateway, subnet mask and DNS servers for my LAN card. Next I have to create a dialer for a PPPoE connection, put in my user name, the service name and the password, and "dial" this connection. And it works fine.

On Ubuntu 10.04, however, I have tried setting things up in a similar fashion - put in all static addresses for the "automatic" wired connection, then put in user name, service name, password for a "DSL" connection. It worked for a while, then stopped. I have tried putting in all the details within the DSL configuration dialog, same thing happened—it worked for a while, then stopped. I have tried deleting the ethernet connection and only keeping the DSL one with all the numbers put in place, same thing happened—it worked for a while, then stopped. Each of the times, when it connected, it connected randomly, after trying a few times, and either stopped working within a few minutes, or after I had rebooted. I have deleted and remade the connection dozens of times—even with different names, but nothing seems to be working.

I have also tried pppoeconf from the terminal, didn't work.

Based on Gilles' suggestion, I have checked /var/log/kern.log, but nothing changes in the file when I try to connect. I have also checked /sbin/route, but gedit can't even open it (says it can't figure the character encoding…).

The "connection established" notification pops up from the top right corner, the same way as when the computer is actually connected to a network.

Can anyone figure what's wrong and how it can be solved?

  • There isn't nearly enough information in your question to help you. Unfortunately, this is the kind of problem where it really helps to be in front of the computer. But we can try if you provide more information. How did you configure the DSL connection? What appears in /var/log/kern.log when the connection is attempted (I think your username and password won't be in the log but check before posting)? After it (what is “it”?) says “Connection established”, what is the output of /sbin/route? Also try to set up a new connection with the same settings: does it work? more than once? Oct 29, 2010 at 21:31
  • Thanks for your comment. I am an almost complete newbie which I probably should've mentioned in my question. But I'll try to gather the info you wanted and also rephrase my question to provide more information and make it clearer.
    – Mussnoon
    Oct 29, 2010 at 23:36

2 Answers 2


I seem to have found the solution.

I deleted all the previous connections, deleted the configuration file from /etc/network created by pppoeconf and rebooted. Then I set up the wired connection (Automatic ethernet) using the static addresses (update: dynamic works now as well) but made sure it didn't have "connect automatically" checked in the configuration dialog. Then I created a DSL connection, but of all the settings, I only filled in the user name, service name and password for it. I checked "available to all users" and closed the settings dialog. Then from the "connections" applet on the panel, clicked the connection name. And it connected and worked.

Nevertheless, after a couple of reboots, I'm noticing that sometimes it won't connect on the first "click". It'll show notification "Connection established" but I won't have internet access. So I need to disconnect and retry a few times, and eventually it works.

Update: I forgot to mention - I had to set the MTU to 1452 as well.


I previously had problems connecting to certain routers via WPA2 with NetworkManager (which was the default in Ubuntu last time I used it). I solved it by installing wicd, which worked.

Note: This doesn't apply if you aren't using a wireless router, or if you don't use WPA2.

  • Think I should've mentioned - it's a wired connection.
    – Mussnoon
    Oct 29, 2010 at 13:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .