14

I recently tried to start samba on manjoro linux.

systemctl start samba.service
systemctl status samba.service
● samba.service - Samba AD Daemon
  Loaded: loaded (/usr/lib/systemd/system/samba.service; enabled; vendor preset: disabled)
  Active: failed (Result: exit-code) since Fri 2017-04-21 10:40:03 SAST; 1s ago
 Process: 5913 ExecStart=/usr/bin/samba $SAMBAOPTIONS (code=exited, status=0/SUCCESS)
Main PID: 5914 (code=exited, status=1/FAILURE)

Apr 21 10:40:02 aaron-pc systemd[1]: Starting Samba AD Daemon...
Apr 21 10:40:02 aaron-pc systemd[1]: Started Samba AD Daemon.
Apr 21 10:40:03 aaron-pc systemd[1]: samba.service: Main process exited, code=exited, status=1/FAILURE
Apr 21 10:40:03 aaron-pc systemd[1]: samba.service: Unit entered failed state.
Apr 21 10:40:03 aaron-pc systemd[1]: samba.service: Failed with result 'exit-code'.  

less /var/log/samba/%m.log 
.....
samba version 4.5.8 started.
Copyright Andrew Tridgell and the Samba Team 1992-2016
[2017/04/21 10:31:05.057860,  0] ../source4/smbd/server.c:466(binary_smbd_main)
At this time the 'samba' binary should only be used for either:
'server role = active directory domain controller' or to access the ntvfs file server with 'server services = +smb' or the rpc proxy with 'dcerpc endpoint servers = remote'
You should start smbd/nmbd/winbindd instead for domain member and standalone file server tasks
[2017/04/21 10:31:05.057905,  0] ../lib/util/become_daemon.c:111(exit_daemon)
STATUS=daemon failed to start: Samba detected misconfigured 'server role' and exited. Check logs for details, error code 22
....

I am not sure what I am missing here.

testparm 
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[printers]"
Processing section "[print$]"
Processing section "[Aaron-share]"
Processing section "[Aaron-movies]"
Loaded services file OK.
Server role: ROLE_STANDALONE

Press enter to see a dump of your service definitions

# Global parameters
[global]
    server services = s3fs, rpc, nbt, wrepl, ldap, cldap, kdc, drepl, winbindd, ntp_signd, kcc, dnsupdate, dns, smb
    server string = %h manjoro linux
    workgroup = ECN
    log file = /var/log/samba/%m.log
    max log size = 1000
    panic action = /usr/share/samba/panic-action %d
    usershare allow guests = Yes
    map to guest = Bad User
    obey pam restrictions = Yes
    pam password change = Yes
    passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
    passwd program = /usr/bin/passwd %u
    server role = standalone server
    unix password sync = Yes
    dns proxy = No
    idmap config * : backend = tdb
1
  • I'm voting to keep this question open as I believe it may be useful to others. Apr 23, 2017 at 23:07

1 Answer 1

24

It was a misunderstanding on my part.

I don't need to start the samba.service.
https://www.samba.org/samba/docs/man/manpages-3/
"samba(8)
Server to provide AD and SMB/CIFS services to clients"

systemctl disable samba
systemctl stop samba

What I actually need is the smbd service.
https://www.samba.org/samba/docs/man/manpages-3/smbd.8.html
"smbd — server to provide SMB/CIFS services to clients"

I don't need to run an AD type setup, I just want to share my files to other pcs.

systemctl enable smb
systemctl start smb
systemctl status smb
systemctl enable nmb
systemctl start nmb
systemctl status nmb

That should be enough to get a working share accessible provided your smb.conf has all the correct settings.

For more information you should read the arch docs
https://wiki.archlinux.org/index.php/samba

I found this links helpful.
https://wiki.manjaro.org/index.php?title=Using_Samba_in_your_File_Manager
https://forum.antergos.com/topic/5557/samba-won-t-start-can-t-share-folders-over-network/3

3
  • It would be best to mark this answer as accepted so that it appears as "answered". Apr 23, 2017 at 23:08
  • 1
    on newer system, the services names are smb and nmb. also you need to install a package before you start these services sudo pacman -S manjaro-settings-samba
    – Alex Jones
    Mar 10, 2019 at 17:14
  • 1
    None of the above worked for me. For users like me, the following solved my issue: run testparm locate/fix any error For me, it was the missing security parameters (defaulting to ADS). Adding this line fixed it ([global]): security = USER Sep 30, 2021 at 17:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .