5

I have a USB audio device, configured as the default device at card 0.

I have a 3rd party application that is attempting to play wav files, which fail with the following:

Playing WAVE 'sound.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Mono
aplay: set_params:1239: Channels count non available

If I try to manually play the very same wav, I get no error but also no sound:

aplay sound.wav
Playing WAVE 'sound.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Mono

If I specify device plughw:0,0, the sound plays correctly!

aplay -D plughw:0,0 sound.wav
Playing WAVE 'sound.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Mono

I have tried various attemps at configuring ~/.asoundrc to set plughw:0,0 as the default, without success.

How can I apply the -D plughw:0,0 be default to all sound playback?

  • That 3rd-party app calls aplay, and uses some wrong parameter(s). Can you configure it somehow? Otherwise, you have to find out what happens there; try replacing /usr/bin/aplay with a script that logs its parameters. – CL. Apr 21 '17 at 6:32
  • Please explain in detail what 3rd party application you use, what ALSA device it uses, and if you can configure it to use other devices. Without any ~/.asoundrc, the default device already is equivalent to plughw + dmix, so there's probably nothing you can do in your ~/.asoundrc alone. – dirkt Apr 21 '17 at 9:12
6

Backup your ~/.asoundrc - if you have one - and add the following, to a new ~/.asoundrc:

pcm.!default { 
 type plug 
 slave { 
 pcm "hw:0,0" 
 } 
} 
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.