I've been using libvirt for a couple of years now and it's worked a treat so far. Just until recently (probably after a few system updates on my Manjaro Linux host): none of my Windows (XP) guests have network connectivity with virtio drivers anymore. Instead I must switch to rtl8139, then network connectivity works fine. As a corollary, I have to wait a very long time in my Windows guests until I can finally check the network adapters settings; otherwise no network icon appears nor does the Network connections window when I right click on Network Favourites and select Properties. The wait period occurs regardless of whether I set IP addresses manually to the interfaces or use DHCP.

I started to notice this issue while booting my old Windows XP virtual machine. It was virtio drivers version 0.1.106 (or close) installed back then. So I upgraded the virtio network drivers first, like I did in the past. Something odd though: updating the driver took forever and I had to forcibly power off the VM and restart it again. I also uninstalled the drivers completely after I switched to rtl8139 then re-installed them again (using Windows Device Manager Non Present Devices trick). No change.

I have tried virtio drivers from the Fedora project version 0.1.135 (latest) and 0.1.126 (stable). No difference. The previous drivers, which used to work back then where from 2013. Needless to say they don't now either. It looks like only my Windows guests are affected. None of my old Linux guests exhibit that glitch as they all receive an IP address from my host's dnsmasq daemon.

Does anyone have an idea?

(N.B.: The event log doesn't reveal nothing about anything going wrong. That said it's no surprise to me.)

  • Is it possible that the virtio drivers simply no longer support XP? Apr 20, 2017 at 21:19
  • 1
    @roaima There's a dedicated folder for XP\x86 on the virtio drivers ISO image so I guess, no, support isn't dropped yet.
    – user86969
    Apr 20, 2017 at 21:24

1 Answer 1


You may be writing about the problem here. This is a bug in qemu 2.8. As a workaround set driver to qemu (instead of vhost) xml file (virsh edit [VmName]) [here] - it worked for me.

  • Thanks a lot! That will [hopefully] help. I'll try this and report. BTW I get an SSL error SSL_ERROR_BAD_MAC_READ with the first link, dunno why.
    – user86969
    Jul 15, 2017 at 11:47

You must log in to answer this question.