1

When connected to DisplayPort 1.2 and suspended with DPMS by waiting or running

sleep 1; xset dpms force off

my monitor cycles every few seconds between backlight off and backlight on with "DisplayPort" shown in the upper left corner. The remainder of the screen is black. The goal is to have it actually stay off.

This is not an issue with input waking the monitor. When connected with HDMI2, it works fine.

Specifications:

  • Samsung LU28E590DS/EN monitor
  • Gentoo Linux recently world updated with stock kernel 4.9.8. But this has been goin on for a couple months.
  • Skylake integrated graphics
  • Intel Alpine Ridge Thunderbolt controller on a Gigabyte Gaming G7 rev 1.0. Same behavior with the built-in DisplayPort or a DisplayPort adapter from the USB Type C Thunderbolt port.
  • Tried both x11-drivers/xf86-video-intel 2.99.917_p20170313 (latest) and 2.99.917_p20170216 (stable), same result

DPMS worked normally on another machine with the same monitor. The other machine runs Ubuntu, also has Skylake integrated graphics, and has a slightly different motherboard from Gigabyte.

This is with Intel integrated graphics. There are scattered reports about NVIDIA and Nouveau drivers Why does monitor stay on when DPMS is enabled? https://devtalk.nvidia.com/default/topic/968059/dpms-not-working-with-displayport-monitor/ .

  • File a bug report with Intel driver developers, and see what they have to say. – dirkt Apr 21 '17 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.