0

I have OpenSSL installed from source and linked the GLIB_LIBS and GLIB_CFLAGS to the correct directories during configure and configured with-SSL

When I try to start syslog-ng (Version 3.6.4) on Ubuntu Server 14.04, I get the following errors:

[2017-04-20T12:39:18.252222] Error opening plugin module; module='afsocket', error='/linux1/lib/syslog-ng/libsyslog-ng-crypto.so: undefined symbol: SSL_library_init'
[2017-04-20T12:39:18.253205] Error opening plugin module; module='dbparser', error='/linux1/lib/syslog-ng/libsyslog-ng-crypto.so: undefined symbol: SSL_library_init'
[2017-04-20T12:39:18.255387] Error opening plugin module; module='afsocket-tls', error='/linux1/lib/syslog-ng/libsyslog-ng-crypto.so: undefined symbol: SSL_library_init'
[2017-04-20T12:39:18.256429] Error opening plugin module; module='cryptofuncs', error='/linux1/lib/syslog-ng/libsyslog-ng-crypto.so: undefined symbol: SSL_library_init'
[2017-04-20T12:39:18.256964] Error opening plugin module; module='syslog-ng-crypto', error='/linux1/lib/syslog-ng/libsyslog-ng-crypto.so: undefined symbol: SSL_library_init'
0

OpenSSL libraries are highly dependent on versions and their ABI changes frequently.

Either your maintain different versions of ssl libraries on your system, or you have to (re)compile also binaries that depend on your new openssl libraries.

  • I don't quite understand. Are you saying I need to reinstall OpenSSL from source? – Anton Rasmussen Apr 20 '17 at 17:11
  • What I am saying is that you if you overwrote/delete the ssl libraries that syslog-ng is counting on with new versions, you have to reinstall also it from source. – Rui F Ribeiro Apr 20 '17 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.