1

I have a computer with a skylake motherboard (ASRock IMB-195), and I'm trying to use the on-board serial port (/dev/ttyS0). I'm using Ubuntu Server with Linux Kernel 4.4.0-72.

If I boot with acpi=off, I get the following output (dmesg):

Serial: 8250/16550 driver, 32 ports, IRQ sharing enabled
serial8250: ttyS0 at I/O 0x3f8 (irq = 4, base_baud = 115200) is a 16550A
serial8250: ttyS1 at I/O 0x2f8 (irq = 3, base_baud = 115200) is a 16550A
serial8250: ttyS2 at I/O 0x3e8 (irq = 3, base_baud = 115200) is a 16550A
serial8250: ttyS3 at I/O 0x2e8 (irq = 3, base_baud = 115200) is a 16550A

with acpi on:

Serial: 8250/16550 driver, 32 ports, IRQ sharing enabled

Completely disabling ACPI is very suboptimal (can't reboot without manually power cycling for example).

Is there a way to disable the parts of ACPI that are preventing the serial driver from working?

  • First step would be to compare dmesg after boot with and without acpi=off, and see what goes wrong. There are also tools to decode the ACPI tables (but the ACPI spec is difficult, this isn't fun). – dirkt Nov 27 '18 at 7:39
2

You can try "acpi=noirq" instead. That's the only way I can get my ttyS0 to work with Serial-Over-Lan on an Intel AMT platform. It doesn't seem to have any ill effects but if anyone else knows a better solution, please share.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.