7

I have installed apache web server and I need to point 127.1.1.1 with alias (www.someaddress.lan) to local apache. What is the proper way to do it? How to point someaddress.lan to default apache page and www.someaddress.lan to /var/www/wordpress/?

11

For your hosts file:

127.1.1.1     someaddress.lan www.someaddress.lan

By the way, don't you mean 127.0.0.1? That is the loopback ip address for localhost. If so, use the following:

127.0.0.1     someaddress.lan www.someaddress.lan localhost.localdomain localhost

Then you need to edit your apache server config file. Usually /etc/httpd/conf/httpd.conf That is where you associate sub domains (Virtual Hosts) with directories containing the content the apache server serves.

Apache Name Based Virtual Hosts

NameVirtualHost *:80

<VirtualHost *:80>
ServerName www.someaddress.lan
ServerAlias www.someaddress.lan
DocumentRoot /var/www/wordpress
</VirtualHost>

<VirtualHost *:80>
ServerName someaddress.lan
ServerAlias someaddress.lan
DocumentRoot /var/www/html
</VirtualHost>
4

If you want to do without installing any kind of DNS server in your machine, then you can put an entry into /etc/hosts file.

 127.1.1.1    www.someaddress.lan    someaddress.lan

Actually ever host before resolving the domain name by contacting its DNS server, first checks its own /etc/hosts file. If it founds that domain entry in that file, it doesn't contact its DNS server.

EDIT: You have to add entries for each in /etc/apache2/sites-enabled/000-default

<VirtualHost *>
   ServerName    someaddress.lan
   DocumentRoot  /var/www/html
</VirtualHost>

<VirtualHost *>
   ServerName    www.someaddress.lan
   DocumentRoot  /var/www/wordpress
</VirtualHost>

NOTE: Don't forget to restart the apache2 server after changing the above configuration file by the following command:

$ sudo /etc/init.d/apache2 restart

  • 1
    Thanks! How to point someaddress.lan to default apache page and www.someaddress.lan to /var/www/wordpress/? – J.Olufsen Apr 8 '12 at 14:27
  • Did you mean to enter the VirtualHost * as VirtualHost *:80 instead? I am having issues being able to access my apache2 server from the internet – freshbtc Aug 30 '17 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.