1

I tried to install a program from source on my Debian-based machine so I ran ./waf configure and this was my output:

Checking for 'gcc' (C compiler) : /usr/bin/gcc Checking for program 'pkg-config' : /usr/bin/pkg-config Checking for 'gobject-2.0' : yes Checking for 'gthread-2.0' : yes Checking for program 'valac-0.8' : not found Checking for program 'valac' : /usr/bin/valac Checking for valac version >= (0, 8, 0) : (0, 34, 7) Checking for program 'msgfmt' : /usr/bin/msgfmt Checking for program 'perl' : /usr/bin/perl Checking for program 'intltool-merge' : /usr/bin/intltool-merge Checking for header locale.h : yes Checking for program 'glib-genmarshal' : /usr/bin/glib-genmarshal Checking for program 'glib-mkenums' : /usr/bin/glib-mkenums Checking for program 'glib-compile-schemas' : /usr/bin/glib-compile-schemas Checking for program 'glib-compile-resources' : /usr/bin/glib-compile-resources Checking for program 'valac-0.28' : /usr/bin/valac Checking for valac-0.28 version >= (0, 28, 0) : (0, 34, 7) Checking for 'glib-2.0' : yes Checking for 'gio-2.0' : yes Checking for 'gobject-2.0' : yes Checking for 'gmodule-2.0' : yes Checking for 'gtk+-3.0' : yes Checking for 'libsoup-2.4' : not found

The problem is: I already have libsoup-2.4-1 installed. And the required dependencies, as stated by the program's author, are:

... libsoup >=2.4 ...

But replacing the new version with the old one would cause some general problems on the system I suppose, so I didn't want to try to do that, nor do I find that smart to do since the new version should work as good as the old one.

What can I do to make this program compilable?

4

You need to install the libsoup development package, libsoup2.4-dev:

sudo apt install libsoup2.4-dev

You need to install libsoup2.4-dev and libsoup2.4-1 (which the -dev package depends on) as a matched pair, with the same version. So if you already have libsoup2.4-1 installed, you need to install the matching libsoup2.4-dev — whether by downgrading libsoup2.4-1 if necessary, or by installing libsoup2.4-dev from the same repository as your installed version of libsoup2.4-1.

  • This package requires libsoup2.48.0-1, but when I try to install this one it says a later version is already installed. – Akito Apr 19 '17 at 11:58
  • What version of libsoup2.4-1 do you have? If you’re running Debian 8 you should have 2.48.0-1. – Stephen Kitt Apr 19 '17 at 12:02
  • 1
    If you have another version of libsoup2.4-1, you need to either downgrade that to 2.48.0-1, or install the matching libsoup2.4-dev (from wherever you got libsoup2.4-1). – Stephen Kitt Apr 19 '17 at 12:13
  • Mos of the dependencies I had to look up on packages.debian.org – Akito Apr 20 '17 at 9:48
0

To add to Stephen's answer, configure uses pkgconfig to check for installed libraries, which in turn reads the configuration from /usr/lib/pkgconfig/libsoup-x.y.pc file. Since you only need this file for development, it is included in -dev package.

Regarding the troubles you have with package versions, this question may be useful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.