I just installed Fedora as a dual-boot (other OS in Win7) on my Dell Inspiron 1750 and, of course, the wireless card is missing firmware.

The wireless card is called Dell Wireless 1397 WLAN mini-card. When I run lspci on Fedora it says that the card is a BCM4312 802.11b/g LP-PHY (rev 01). Some internet searching shows that this card has had a lot of problems before.

I don't have access to wired internet, but I do have a USB flash drive. I'm using the instructions for Linux drivers from Broadcom's own website. To quote,

Some of the major linux distros already supply a version of this driver, so you don't have to compile your own. Most of the distros keep this driver along with other proprietary or non-GPL drivers in a separate repository.

For further information see the documentation for your specific distro.

Fedora: ------ su -c 'rpm -Uvh

http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm

su - yum update yum install kmod-wl

So I download the two .rpm files on Windows and copy them to Fedora, then use rpm -ivh ... on them. No idea what that does, but internet still doesn't work. Obviously I can't use yum because I don't have internet.

Is there a way where I can just download whatever I need, put the stuff on USB, and just install it with rpm or whatever? Because the fact that every tutorial out there assumes that the user has access to wired internet is killing me.

  • 2
    Fedora 16 is dead as a doornail. There isn't any really clean upgrade path anymore, better reinstall from scratch. And I believe latest Fedora supports the card out-of-the-box.
    – vonbrand
    Commented Mar 19, 2014 at 2:51

1 Answer 1


You need the file called broadcom-wl-, which a quick internet search shows several places to download.

Put that on a USB stick, go to Fedora, navigate to right directory, and run

tar xvjf broadcom-wl-r.150.10.5.tar.bz2 && cd broadcom-wl-
broadcom-wl-r.150.10.5/driver su b43-fwcutter -w /lib/firmware wl_apsta_mimo.o

Then restart Fedora. Boom! Internet.

  • The right directory is usually /lib/firmware/
    – eyoung100
    Commented Dec 9, 2014 at 14:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .