0

I have downloaded the Debian 8 AMD x64 iso and have attempted to make a bootable USB using Rufus on my PC and I have also tried this using UNetbootin on Ubuntu.

I was expecting a graphical user interface to install the OS as I had on my virtual machine but instead I get a command line interface labelled GRUBv2.

The laptop BIOS will boot to USB and has done before for the Ubuntu install so unsure how to get Debian to install via GUI.

How to fix?

  • 1
    GRUB is the bootloader, so if that's all you see then the OS is not booting. Does GRUB give you any options to choose from? If all you get is a command prompt, then you're missing the GRUB configuration file. – Emmanuel Rosa Apr 18 '17 at 21:15
  • If i hit tab I get a list of commands like boot, ls, etc – bigdaveygeorge Apr 18 '17 at 21:16
  • 1
    Yeah, you're in the GRUB bootloader. It couldn't find a config file where it expected it, hence it dropped you at the shell. Debian advises against using UNetbootin. Instead, simply write the ISO to the USB drive's block device. See debian.org/CD/faq/#write-usb – Emmanuel Rosa Apr 18 '17 at 21:42
  • I have tried the cp <file> <device> option, this time it shows the GRUB menu with the option to boot into Ubuntu (my current OS) but no Debian option. – bigdaveygeorge Apr 18 '17 at 22:44
  • Unfortunately, there's not much more I can advise without the hardware in my hands. A number of things could be wrong, and it would take trial and error to figure it out. Since you have Ubuntu already installed, you can use Debootstrap to install a base Debian system from within Ubuntu. However, that's an advanced installation method; no GUI. Also keep in mind that when dual-booting Linux OSs you'll want only one of them to be in charge of maintaining the GRUB configuration. manpages.debian.org/jessie/debootstrap/debootstrap.8.en.html – Emmanuel Rosa Apr 18 '17 at 23:32
1

Are you sure, that the GRUB is loaded from your stick? Have you enabled booting from USB device on your PC? For writing Linux ISO to external device use dd command.

0

Fixed by using Rufus in Windows to create the boot USB stick and ensuring DD Image Mode was used instead of the default ISO Image Mode. There is an alert that mentions this when attempting to create a Debian USB in ISO image mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.