0

My soundcard is not detected on Linux Mint 18.1 (Kernel 4.4) after a fresh dual-boot install (only Dummy output in the sound control, and no soundcard detected in alsa).

It also seems that it has broken the sound on Windows (no soundcard detected).

My setup : Asus UX410UQ-GV044T with Intel Kabylake i7 processor, integrated 620 graphics + dedicated 940mx nvidia, 16Go RAM, 256Go SSD, 1To HDD, UEFI with secureboot disabled, CSM compatibility mode disabled.

Where I think the problem comes from : Since the Linux install seems to have broken the audio for both Linux and Windows, and it is not a hardware issue (cf. below), it leads me to think that the GRUB bootloader has something to do with it ...

What I already tried :

  • Restoring the hardrive to its initial state with Windows only => The soundcard is detected correctly after rebooting. This means that it is not a hardware problem.

  • sudo alsa force-reload => Did not solve anything

  • lspci does not show any audio device

  • Installing pavucontrol => Did not solve anything

  • Running the linux Mint live-usb after restoring the initial Windows install that works ==> The soundcard is now detected (in alsa, sound control center, pulse audio volume control, lspci ...) but no sound comes out of the speakers..

What I will try next :

  • Try running live-usb with distributions that have more recent kernels (4.8 and above). I have read that it could solve some compatibility issues between recent hardware (e.g. linux mint 18.1 audio problem)

  • If I find one that works, try and install it and see if the problem persists...

For the moment I am stuck with the Windows only configuration ...

Edit : I solved the issue by moving to Manjaro, with kernel 4.9. The live-usb worked, as well as the installed system with dual-boot. It seems that it was a kernel issue AFAIK.

  • If lspci sometimes lists and sometimes doesn't list the sound card, either your BIOS or your ACPI does some really funny stuff. You don't need to look into ALSA, grub etc. if it doesn't appear in lspci. Please provide an lspci output with and without soundcard, and also compare dmesg after boot with and without soundcard. If you can't make sense of dmesg, put both variants in a pastebin and edit your question with a link. – dirkt Apr 18 '17 at 15:08
  • I solved the issue by moving to Manjaro, with kernel 4.9. The live-usb worked, as well as the installed system with dual-boot. It seems that it was a kernel issue AFAIK. – mhham Apr 18 '17 at 22:58
  • The solution you found would be best posted as an answer, and the fact that our worked recorded by accepting that answer, rather than editing the title. – dhag Apr 18 '17 at 23:01
  • Thank you for your comment. I modified the title, and added an answer – mhham Apr 18 '17 at 23:03
1

I solved the issue by moving to Manjaro, with kernel 4.9. The live-usb worked, as well as the installed system with dual-boot. It seems that it was a kernel issue AFAIK.

1

After installing linux mint 18.1 Cinnemon as a dual boot next to W10 pro the sound card was not detected for both W10 & Linux. A w10 recovery didn't change anything.(it did not erase the linux partition:)) I solved my problem by going into the bios and restore settings -> factory settings. Hope that this will work for other people as well.

Dell inspiron 7000.

Fredo

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.