0

Have a laptop Lenovo thinkpad edge E520 which I installed Linux Mint on and everything worked perfectly until the last upgrades. After the restart, I had no internet anymore. Have tried both cable and wireless unsuccessfully. Down near the clock, I see that the network cable is connected and when I take the cord out changes the icon to the wireless symbol.

So this shows that the Internet should work as it shows the cable or wireless icon near the clock. But for some reason can not make the rest of the software to see this. The browser is not able to connect to the network and when I run the upgrade program, it will find neither the internet. Have TeamViewer on it and it does not work as it can not connect to the net.

However, as stated then displays the icons down by the clock that the laptop is connected to the network, either on cable or wireless. Have tried rebooting several times and one time everything worked and it was on the internet. But it was just the one time.

2
  • 2
    Google translate did a pretty good job. Hopefully someone will be able to help... – Stephen Rauch Apr 18 '17 at 1:44
  • A list of what was installed during the update probably will be helpful. I do not know how get such a list in Linux Mint, but others may. Knowing what was installed will make it easier to find what changed. – Chindraba Apr 18 '17 at 1:59
0

There isn't really enough information to be able to identify your issue exactly.

What I would recommend is start with the network basics. proceed only once your have confirmed each step is valid.

  1. Cable connected/not connected
  2. Identify IP Address/Subnet Mask/Gateway of both the machine and gateway/router (Linux command in Terminal is ifconfig)

you should get something along the lines of

inet addr:xxx.xxx.xxx.xxx Bcast:xxx.xxx.xxx.xxx Mask:xxx.xxx.xxx.xxx

  1. Try running a ping -n -c 4 xxx.xxx.xxx.xxx (first try your IP, then try your gateway) - replace the x with your actual IP address. the -n prevents unnecessary lookups as suggested by Michael and the -c 4 means to try 4 pings and then stop/print out a summary.
  2. try doing a DNS lookup (command for this nslookup name.domain.com) - would suggest doing nslookup www.google.com
1
  • I recommend ping -n instead of ping to be certain that you aren't doing unnecessary name lookups. – user Apr 18 '17 at 8:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.