2

Somehow I got vlc3.x installed on my Fedora 25, it is not working at all.

I found I could downgrade the package to 2.x,

sudo dnf downgrade vlc --allowerasing -y
Failed to synchronize cache for repo 'phnxrbrn-evopop', désactivation.
Vérification de l'expiration des métadonnées effectuée il y a 1:59:20 sur Mon Apr 17 22:27:33 2017.
Dépendances résolues.
===============================================================================================================================
 Package                                   Architecture    Version                       Dépôt                           Taille
===============================================================================================================================
Installation de:
 gstreamer1-plugins-bad-free               x86_64          1.10.4-1.fc25                 updates                         1.8 M
 gstreamer1-plugins-bad-freeworld          x86_64          1.10.4-1.fc25                 rpmfusion-free-updates          193 k
 live555                                   x86_64          2016.10.21-1.fc25             rpmfusion-free                  360 k
Suppression:
 gstreamer1-plugins-bad                    x86_64          1:1.10.4-2.fc25               @fedora-multimedia              7.4 M
 live555-libs                              x86_64          1:2016.11.06-2.fc25           @fedora-multimedia              1.2 M
Retour à la version précédente:
 ffmpeg-libs                               x86_64          3.1.7-1.fc25                  rpmfusion-free-updates          6.0 M
 vlc                                       x86_64          3.0.0-0.16.fc25               rpmfusion-free-updates          1.8 M
 vlc-core                                  x86_64          3.0.0-0.16.fc25               rpmfusion-free-updates          7.9 M
 x265                                      x86_64          1.9-3.fc25                    rpmfusion-free                   42 k
 x265-libs                                 x86_64          1.9-3.fc25                    rpmfusion-free                  557 k

Résumé de la transaction
===============================================================================================================================
Installation                    3 Paquets
Supprimer                       2 Paquets
Retour à la version précédente  5 Paquets
...

But now if i run an update, that will also update vlc.

$ sudo dnf update
Failed to synchronize cache for repo 'phnxrbrn-evopop', désactivation.
Vérification de l'expiration des métadonnées effectuée il y a 2:02:35 sur Mon Apr 17 22:27:33 2017.
Dépendances résolues.
===============================================================================================================================
 Package                         Architecture    Version                                      Dépôt                      Taille
===============================================================================================================================
Installation de:
 gstreamer1-plugins-bad          x86_64          1:1.10.4-2.fc25                              fedora-multimedia          2.3 M
     replacing  gstreamer1-plugins-bad-free.x86_64 1.10.4-1.fc25
     replacing  gstreamer1-plugins-bad-freeworld.x86_64 1.10.4-1.fc25
 live555-libs                    x86_64          1:2016.11.06-2.fc25                          fedora-multimedia          368 k
     replacing  live555.x86_64 2016.10.21-1.fc25
Mise à jour:
 ffmpeg-libs                     x86_64          1:3.2.4-2.fc25                               fedora-multimedia          6.2 M
 vlc                             x86_64          1:3.0.0-18.20170322git9513f34.fc25           fedora-multimedia          1.5 M
 vlc-core                        x86_64          1:3.0.0-18.20170322git9513f34.fc25           fedora-multimedia          8.6 M
 x265                            x86_64          1:2.3-2.fc25                                 fedora-multimedia           42 k
 x265-libs                       x86_64          1:2.3-2.fc25                                 fedora-multimedia          1.7 M
Paquets ignorés suite à des dépendances cassées:
 live555                         x86_64          1:2016.11.06-2.fc25                          fedora-multimedia          108 k

Résumé de la transaction
===============================================================================================================================
Installation   2 Paquets
Mettre à jour  5 Paquets
Ignorer        1 Paquet

Taille totale des téléchargements : 21 M

It is not expected for me, i miss something.

What should I do to update the system but keep vlc 2.x until I decided to move on 3.x ?

1

I am not in front of a Fedora system at the moment but I think you can exclude one or more packages using the --exclude option:

$ sudo dnf update --exclude=<PACKAGE-NAME>
3

The other answer with command-line option is obviously correct, but more appropriate solution is to write that into configuration file, so you don't have to think about it with every update. The file is /etc/dnf/dnf.conf, where you should append:

exclude=vlc
  • I accepted other answer because you already have a lot of points! but i read and appreciated, thanks – mh-cbon Apr 18 '17 at 7:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.