6

Is there any way I can hide the ctags: Warning: ignoring null tag in warning from prointing on the shell when I execute ctags in the src/? All of these warning seem to refer to .js files which is out of scope for me. I'm working with .c files under the hood but they are in thesame top level directory (src/) and I run the following command: ctags -R *;cscope -R from src/ in order to browse the existing code but I get all these messages from a directories I don't "care" about.

  • So rather than use * which will include all the .js files throwing the warning, why not just use *.c (or *.cpp, etc.) to only run ctags on the C code, thereby avoiding the warning in the first place? – DopeGhoti Apr 17 '17 at 18:23
  • because there's no source files in src/ itself, all sources are within subdirectories... – cerr Apr 17 '17 at 18:25
  • 2
    Try --exclude='*.js', which some versions of ctags support. – Mark Plotnick Apr 17 '17 at 19:08
  • @MarkPlotnick that's it! You can add your comment as an answer and i'll accept! Thanks! – cerr Apr 17 '17 at 19:47
4

When you give ctags the -R (recurse) option, it's often useful to use the --exclude option to tell it to ignore things like source control directories or files you're not interested in indexing.

In your case, use the option --exclude='*.js' .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.