I'm trying to install backport 4.4.2-1 on my Kali-Rolling vm machine but I'm getting the following error. I have no idea what went wrong but what I did was first install the linux headers using the following command --> #apt-get install linux-headers-$(uname -r) Everything went well. But When i tried to make install, I got the following error. Please help me. Are there any dependencies missing???

make[4]: 'conf' is up to date.
boolean symbol HWMON tested for 'm'? test forced to 'n'
boolean symbol HWMON tested for 'm'? test forced to 'n'
# configuration written to .config
Building backport-include/backport/autoconf.h ... done.
  CC [M]  /root/Downloads/backports-4.4.2-1/compat/main.o
In file included from /root/Downloads/backports-4.4.2-1/backport-
                 from <command-line>:0:
/usr/src/linux-headers-4.9.0-kali3-common/include/asm-generic/qrwlock.h: In 
function ‘__qrwlock_write_byte’:
error: implicit declaration of function ‘config_enabled’ [-Werror=implicit-
 #define IS_BUILTIN(option) config_enabled(option)
generic/qrwlock.h:156:26: note: in expansion of macro ‘IS_BUILTIN’
  return (u8 *)lock + 3 * IS_BUILTIN(CONFIG_CPU_BIG_ENDIAN);
/usr/src/linux-headers-4.9.0-kali3-common/include/asm-generic/qrwlock.h:156:37: error: ‘CONFIG_CPU_BIG_ENDIAN’ undeclared (first use 
in this function)
  return (u8 *)lock + 3 * IS_BUILTIN(CONFIG_CPU_BIG_ENDIAN);
note: in definition of macro ‘IS_BUILTIN’
 #define IS_BUILTIN(option) config_enabled(option)
generic/qrwlock.h:156:37: note: each undeclared identifier is reported only 
once for each function it appears in
  return (u8 *)lock + 3 * IS_BUILTIN(CONFIG_CPU_BIG_ENDIAN);
note: in definition of macro ‘IS_BUILTIN’
 #define IS_BUILTIN(option) config_enabled(option)
cc1: some warnings being treated as errors
/usr/src/linux-headers-4.9.0-kali3-common/scripts/Makefile.build:298: recipe 
for target '/root/Downloads/backports-4.4.2-1/compat/main.o' failed
make[7]: *** [/root/Downloads/backports-4.4.2-1/compat/main.o] Error 1
/usr/src/linux-headers-4.9.0-kali3-common/scripts/Makefile.build:549: recipe 
for target '/root/Downloads/backports-4.4.2-1/compat' failed
make[6]: *** [/root/Downloads/backports-4.4.2-1/compat] Error 2
/usr/src/linux-headers-4.9.0-kali3-common/Makefile:1507: recipe for target 
'_module_/root/Downloads/backports-4.4.2-1' failed
make[5]: *** [_module_/root/Downloads/backports-4.4.2-1] Error 2
Makefile:150: recipe for target 'sub-make' failed
make[4]: *** [sub-make] Error 2
Makefile:8: recipe for target 'all' failed
make[3]: *** [all] Error 2
Makefile.build:6: recipe for target 'modules' failed
make[2]: *** [modules] Error 2
Makefile.real:88: recipe for target 'modules' failed
make[1]: *** [modules] Error 2
Makefile:40: recipe for target 'install' failed
make: *** [install] Error 2

You don't need to install backports on kali rolling release , Backports is geneally used on debian-stable based distro

Backports are packages taken from the next Debian release (called "testing"), adjusted and recompiled for usage on Debian stable. Because the package is also present in the next Debian release, you can easily upgrade your stable+backports system once the next Debian release comes out. (In a few cases, usually for security updates, backports are also created from the Debian unstable distribution.)

  • so, how can I enable "wlan0" interface on my kali machine. #iwconfig doesn't show up any wireless interfaces either. Please help!!! – Stewart Apr 17 '17 at 19:00
  • @Stewart If you are using a wifi USB adapter add the lsusb – GAD3R Apr 17 '17 at 19:09
  • Hi! typing the above command #lspci -knn | grep Net -A2 shows nothing. I'm not using any USB adapter. I'm using Kali Linux in vmware. Also, doing #iwconfig shows the following output : lo no wireless extensions. eth0 no wireless extensions – Stewart Apr 17 '17 at 19:15
  • @Stewart why you can't get a wifi connection on VMware unix.stackexchange.com/a/135024/153195 – GAD3R Apr 17 '17 at 19:31
  • hi!! thanks for the replies. Any possibility of enabling wifi connection in Virtual Box for Kali-guest OS? – Stewart Apr 18 '17 at 5:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.