2

Suddenly after trying wayland and switching back to Xorg, middle button emulation stops of working.

Below my system information:

 OS: Fedora 25 TwentyFive
 Kernel: x86_64 Linux 4.10.8-200.fc25.x86_64
 Shell: bash
 DE: KDE 5.33.0 / Plasma 5.8.6
 WM: KWin
 WM Theme: Aurorae

libinput shows this about touchpad as follows:

Device: SynPS/2 Synaptics TouchPad Kernel: /dev/input/event6 Group: 7 Seat: seat0, default Size: 98.04x48.03mm Capabilities: pointer Tap-to-click: disabled Tap-and-drag: enabled Tap drag lock: disabled Left-handed: disabled Nat.scrolling: disabled Middle emulation: n/a Calibration: n/a Scroll methods: *two-finger edge Click methods: none Disable-w-typing: enabled Accel profiles: none Rotation: n/a

xinput says:

xinput list-props 12
Device 'SynPS/2 Synaptics TouchPad':
        Device Enabled (115):   1
        Coordinate Transformation Matrix (117): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
        libinput Tapping Enabled (252): 0
        libinput Tapping Enabled Default (253): 0
        libinput Tapping Drag Enabled (254):    1
        libinput Tapping Drag Enabled Default (255):    1
        libinput Tapping Drag Lock Enabled (256):       0
        libinput Tapping Drag Lock Enabled Default (257):       0
        libinput Tapping Button Mapping Enabled (258):  1, 0
        libinput Tapping Button Mapping Default (259):  1, 0
        libinput Accel Speed (260):     0.000000
        libinput Accel Speed Default (261):     0.000000
        libinput Natural Scrolling Enabled (262):       0
        libinput Natural Scrolling Enabled Default (263):       0
        libinput Send Events Modes Available (237):     1, 1
        libinput Send Events Mode Enabled (238):        0, 0
        libinput Send Events Mode Enabled Default (239):        0, 0
        libinput Left Handed Enabled (264):     0
        libinput Left Handed Enabled Default (265):     0
        libinput Scroll Methods Available (266):        1, 1, 0
        libinput Scroll Method Enabled (267):   1, 0, 0
        libinput Scroll Method Enabled Default (268):   1, 0, 0
        libinput Disable While Typing Enabled (269):    1
        libinput Disable While Typing Enabled Default (270):    1
        Device Node (240):      "/dev/input/event6"
        Device Product ID (241):        2, 7
        libinput Drag Lock Buttons (271):       <no items>
        libinput Horizontal Scroll Enabled (272):       1

I can't set it by hand:

xinput set-prop  '12' 'libinput Middle Emulation Enabled' 1
property 'libinput Middle Emulation Enabled' doesn't exist, you need to specify its type and format

Is there a conflict between Wayland and Xorg? How can I reset the middle button emulation of mousepad?

UPDATE

I've found libinput-debug-events outputs:

-event6   POINTER_BUTTON    +2.50s      BTN_MIDDLE (274) pressed, seat count: 1
 event6   POINTER_BUTTON    +2.72s      BTN_MIDDLE (274) released, seat count: 0

So it's matter of paste problem (in fact, text is copied in klipper), any ideas?

1 Answer 1

2

I've found the reason. I've created a Mouse Gesture Action in Plasma System Setting, and if I choose button 2 paste with emulated middle button does not work.

Changing button to 3 fixes the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .