0

This might look stupid but i need to know. What if the initdefault is set to 0 or 6 in my redhat7 system. How to revert it back. As you can see i'm no expert so please give me a detailed explanation.

0

You need to access your Redhat OS via emergency or rescue mode. To do this, when your OS is booting up and grub2 prompts you for boot time selection press 'e' on your boot choice to edit the boot time parameters.

Look for the linux with 'linux16' and at it's end append the string "systemd.unit=rescue.target" (without qoutes). Enter Ctrl+X to boot with the parameter you provided. This will take you to rescue mode where you will enter you root password. On RH7 systemd handles runlevels. Enter:

systemctl set-default multi-user.target #to boot in runlevel 3

or if you want to boot into graphical interfaces:

systemctl set-default graphical.target #boot into runlevel 5

To check what runlevel you are at currently:

systemctl get-default

After changing the default runlevel target. Reboot your system and it will boot into the given new default run level.

Here's a helpful link of how you can boot into emergency or rescue mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.