0

I recently bought an SSD (Samsung Evo 850) and installed Ubuntu on it. I have Windows 10 on my mSata drive and another HDD which I use to store Data. My mSata is strangely formatted but it was shipped that way. All other drives just have one partition each.

The installation was fine and completed without errors. When I try to boot, the grub menu appears and I can choose my Windows and boot without a problem. But when I try to boot into the newly installed Ubuntu I will always get an error message which says something like:

error: failure reading sector 0xf1ec400 from 'hd0'.

alloc magic is broken at 0x8f1464e0: 8f08aa60"

However the sector adress is changing

I tried to repair grub as shown in here: https://askubuntu.com/questions/88384/how-can-i-repair-grub-how-to-get-ubuntu-back-after-installing-windows

But this approach didn't help. Also I tried to use the Boot-repair programm from a LiveDisk as suggested here: https://help.ubuntu.com/community/Boot-Repair

The result is posted here: http://paste2.org/185NweyH

Can someone help me?

EDIT: I could now finally boot by changing the BIOS setting from AHCI to IDE. So whats the problem. I thought Ubuntu can deal with AHCI?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.