136

I was able to make GNU Screen start counting windows with the number 1 instead of the default 0 with this code in my .screenrc:

# Get rid of screen 0
bind c screen 1
bind ^c screen 1
bind 0 select 10

When I created windows in .screenrc I used screen 1 so that it would first try 1 and then count up if that window number was taken.

1 Answer 1

212

The solution is to modify ~/.tmux.conf to:

# Start windows and panes at 1, not 0
set -g base-index 1
setw -g pane-base-index 1

Edit: unlike base-index, pane-base-index is a window option, so setw should be used, as @Jogusa pointed out.

11
  • 58
    I wish they made this default, its really inconvenient as 0 as at the other side of the keyboard. Oct 30, 2012 at 6:26
  • 5
    According to my tmux book it shoud be setw in the pane setting: setw -g pane-base-index 1 See the .tmux.conf from book: media.pragprog.com/titles/bhtmux/code/config/tmux.conf
    – Jogusa
    Sep 26, 2014 at 11:43
  • 4
    setw is alias for set-window-option or set -w. Altering pane-base-index is a window option. See tmux manpage -> manpages.ubuntu.com/manpages/precise/man1/tmux.1.html
    – Jogusa
    Sep 27, 2014 at 10:21
  • 6
    i still have no idea, up till this day, why numbers on the keyboard start from 1 instead of 0. what kind of ordering is that?
    – Gerald
    Aug 8, 2018 at 4:28
  • 6
    Note that tmux has to restart for windows to start at 1. In contrast, panes will start at 1 just by doing <prefix> :source-file ~/.tmux.conf.
    – llf
    Jan 2, 2020 at 21:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .