9

For the last month or so, I've been attempting to get jetbrains-toolbox to work. It used to work (and is how I installed IntelliJ IDEA and Gogland.) When I went to update the IDEA

I'm currently using Arch. Here are the things I have tried.

  1. Loading jetbrains-toolbox from within Sway.
  2. Reinstalling jetbrains-toolbox from the aur.
  3. Reinstalling jetbrains-toolbox from the Jetbrains website.
  4. Launching it with --disable-gpu
  5. Clearing ~/.local/share/JetBrains/Toolbox
  6. Googling all messages that I get.
  7. Loading jetbrains-toolbox in different DEs. I tried GNOME, KDE, and i3.

The settings file (~/local/share/JetBrains/Toolbox/.settings.json), even after being cleared by action number 5, is able to regenerate, so I assume that there is something, somewhere on my filesystem that it isn't going away. This is what I think might be causing the problems. I have verified that the settings file was deleted by looking at Thunar's trash folder. However, doing a search for my email address (contained in the settings file) from ripgrep did not turn up anything relevant.

These are the commands I ran:

  1. cd ~/ sudo rg --hidden "MY_EMAIL_HERE" >> ~/Desktop/home_search.txt
  2. cd /usr/ sudo rg --hidden "MY_EMAIL_HERE" >> ~/Desktop/home_search.txt

The only relevant results of this were: .local/share/JetBrains/Toolbox/.settings.json: "email": "MY_EMAIL_HERE", .local/share/Trash/files/Toolbox/.settings.json: "email": "MY_EMAIL_HERE",

I'm not exactly proficient with Linux, but I've been asking around for help with this for a while. If you have any advice, please have patience with me. I might be a bit stupid.

When I run it from the terminal, this is the message that shows up:

john@john ~/D/jetbrains-toolbox-1.2.2314> ./jetbrains-toolbox [0415/155414:WARNING:resource_bundle.cc(311)] locale_file_path.empty() for locale

This is a message that will show up occasionally through a system tray notification (it does not use my notification daemon):

failed to find application to url: share/jetbrains-toolbox/jetbrains-toolbox

Maybe I need some folder in /usr/share or ~/.local/share named jetbrains-toolbox? I do not have that folder in either location.

These are two log files. One is from executing ToolBox and leaving it open for a bit. Another is from uninstalling ToolBox from the aur and deleting ~/.local/share/JetBrains/Toolbox and leaving it open for a bit. They have been labeled appropriately. https://gist.github.com/gonzalezjo/4cf09eb4b7ad849df5557fd297a7061c

When I open ToolBox, I'm greeted with a black screen. After about 15 seconds, it becomes white. Here's an imgur gallery showcasing this. http://imgur.com/a/JS08D

(Note: I don't have enough reputation to include these as separate images while still including a link to the logs. Sorry about that :\)

From the moment the black screen shows to the moment it becomes white, I've timed it down to an average of 13.7 seconds using a stopwatch app on my phone and three trials. From the moment I type ./jetbrains-toolbox to the moment it becomes white, it's an average of about 16.1 seconds. Again, three trials.

My CPU is a Haswell i7 (i7-4790k) and my GPU is Pascal (Nvidia's GTX 1050). I think it's possible that this could be graphics driver or X related (or both? I am clueless here.) based off of a scary experience upgrading drivers prevented me from entering a DE. That experience was resolved after xorg (or something like that?) and the nvidia package were reinstalled.

According to nvidia-smi, my driver version is:

NVIDIA-SMI 378.13 Driver Version: 378.13

I've tried to provide all the information I can, but if anything else is needed, I'm happy to provide.

1
  • It will be fixed in .5xxx release by Jetbrains. I even linked the bug task from their tracker to Arch forums.
    – Kaspar
    Oct 11 '17 at 18:08
14

Just launch with --disable-seccomp-filter-sandbox and it should work.

I found it in https://bbs.archlinux.org/viewtopic.php?id=229859

2

So I spent about a month struggling with packages and downloads everywhere, with tons of googling, asking around etc., to no avail. I made this post and within about an hour, messing around in my file manager, completely clueless, I somehow managed to fix this. Welp. Sorry... Here's exactly what I did. Hurray for desperation, I guess?

  1. Install the jetbrains-toolbox package from the AUR.

  2. Go to /opt/JetBrains/Toolbox (found by looking at the PKGBUILD)

  3. Navigate to /opt/JetBrains/Toolbox/bin/ to find jetbrains-toolbox, an executable. I copied this to a folder I made in documents named ToolboxResearch/.
    (Run mkdir -p ~/Documents/ToolboxResearch/Extracted, then run cp /opt/JetBrains/Toolbox/bin/jetbrains-toolbox ~/Documents/ToolboxResearch).

  4. Navigate to ~/Documents/ToolboxResearch

  5. Extract it using Ark to the Extracted folder.

  6. You should have a file hierarchy that looks like so: ~/Documents/ToolboxResearch/Extracted/jetbrains-toolbox/. I copied this from the file path bar of Thunar, my file manager of choice, so if I made a mistake anywhere up to this point, you can rest assured that this part is correct.

  7. To avoid confusing myself with /usr/ and usr/, I ran mv ~/Documents/ToolboxResearch/Extracted/jetbrains-toolbox/usr ~/Documents/ToolboxResearch/Extracted/jetbrains-toolbox/store.

  8. I edited ~/Documents/ToolboxResearch/Extracted/jetbrains-toolbox/Jetbrains Toolbox to have these contents:

    Type=Application
    Name=JetBrains Toolbox
    Exec=/home/john/Documents/ToolboxResearch/Extracted/jetbrains-toolbox/store/bin/jetbrains-toolbox %u
    Icon=/store/share/jetbrains-toolbox/toolbox.svg
    StartupNotify=false
    Terminal=true
    MimeType=x-scheme-handler/jetbrains;
    

    The changes I made are specifically limited to Exec, Icon, and Terminal. I changed Terminal to true just to see what it did and I changed Icon and Exec to reflect the new file paths. I highly doubt that this did anything though.

    You will want to change "john" to reflect your home directory instead of mine.

  9. I opened ~/Documents/ToolboxResearch/Extracted/jetbrains-toolbox/store/bin/jetbrains-toolbox (again, copy-pasting from Thunar) in my editor and edited line 5, which starts with path=. I changed it to path=~/Documents/ToolboxResearch/Extracted/jetbrains-toolbox/store/share/$app.

  10. Navigated to ~/Documents/ToolboxResearch/Extracted/jetbrains-toolbox/store/bin/ in my terminal.

  11. Ran ./jetbrains-toolbox

  12. It worked!

Sorry for making this post. I Never would've thought that I'd figure this out so soon after I made it. I actually thought I was hopeless.

If someone has this problem and can't fix it even after reading this, you can leave a reply and I'll hopefully be able to help you out. My apologies if this explanation wasn't very clear.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.