2

I have successfully installed the printer drivers as indicated here, which should include the scanner drivers.

Indeed, brscan2 and brscan-key are installed; I have also installed brother-udev-rule-type1; sane, sane-utils and xsane are installed too.

The printer is connected through USB and it works (is able to print), but the integrated scanner cannot be used.

Until this point simple-scan or xsane cannot see the scanner, not even if run with sudo.

enter image description here

enter image description here


Scanner becomes visible in the Simple Scan and Xsane settings after copying /usr/lib64/sane to /usr/lib (as suggested here). But then simple-scan gives a different error ("Unable to start scan") and xsane says "Failed to open device 'brother2:bus2;dev3':Invalid argument". - The same with sudo.

enter image description here

enter image description here


Adding

# Brother scanners
ATTRS{idVendor}=="04f9", ENV{libsane_matched}="yes"

in /lib/udev/rules.d/40-libsane.rules didn't help either.


Edit

after answer by pfnuesel:

lssub gives:

Bus 001 Device 003: ID 04f9:0169 Brother Industries, Ltd DCP-110C RemovableDisk

then I did sudo chmod a+w /dev/bus/usb/001/008 with no effect, as this is not (I guess) a permissions problem.


I have also tried without success to copy file from /usr/lib64 and /usr/lib64/sane to /usr/lib/x86_64-linux-gnu/sane and /usr/lib/x86_64-linux-gnu, as indicated here and here.


Looking at this post here which mentions an advanced usb configuration in BIOS (the one discussed here - see also the image there) which may be needed for the present purpose, I have found a similar but somewhat different setting.

The above setting is also mentioned here, along other settings that I have tried to follow, but none worked.

I see no XHCI pre boot option in my BIOS - but I see "USB Mass storage driver support" which is enabled.

enter image description here

Disabling it changes nothing in any of the two usb ports (one is 2.0, the other 3.0).


update

after following this post that says to use

export SANE_DEBUG_DLL=128
scanimage -L

look for errors of the form No such file or directory and copy the specified file at the specified location, I only got these errors:

[dll] load: trying to load `/usr/lib/x86_64-linux-gnu/sane/libsane-v4l.so.1'
[dll] load: couldn't open `/usr/lib/x86_64-linux-gnu/sane/libsane-v4l.so.1' (No such file or directory)
[dll] load: trying to load `/usr/lib/sane/libsane-v4l.so.1'
[dll] load: couldn't open `/usr/lib/sane/libsane-v4l.so.1' (No such file or directory)
[dll] load: couldn't find backend `v4l' (No such file or directory)

But these files seem absent (tested with locate)... and, based on the answer to my separate question on this matter (What is libsane-v4l.so.1 and how do I get it?), they are probably not needed for my purpose.

0

I have a different scanner and a different OS, so my help might be of limited value. But let's try anyway.

When you plug in the printer, you can run lsusb to find out what bus number and what device number is assigned to your printer.

Then grant write permissions to your device

chmod a+w /dev/bus/usb/$BUS/$DEVICE

where $BUS and $DEVICE are the bus and device numbers noted earlier. Then try again to scan with xsane.

  • It doesn't change anything. It looks like it addresses a permission issue; in this case it would have already worked with sudo, but I stated in the question that it doesn't. – user32012 Apr 15 '17 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy