1

I'm using the mac-terminal to connect via ssh to my server and my locales on both my server and my mac are set to de_DE.UTF-8. Every time I try to enter ö, ä or ü it just writes öäü in vim. This happens on my server and local so I think if the problem is solved locally, it can be solved easily on my server. :set encode=utf-8 and :set termencode=utf-8 doesn't change the behaviour, however when I try :set encode=latin1 instead, it writes the actual ö, ä and ü but it also adds a space after each letter: ö ä ü My terminal settings are set to utf-8 and several encodings are activated including utf-8 and latin1.

Has anyone any ideas where I can try to solve this awkward problem? Thanks a lot in advance!

3
  • Sounds like a Terminal.app issue. Have you made sure your local settings are correct? See e.g. stackoverflow.com/a/24770092/102182
    – Mikel
    Apr 15 '17 at 3:57
  • No problem with umlauts in the terminal itself or other editors?
    – Philippos
    Apr 15 '17 at 4:44
  • Thanks a lot you too! (in nano I had problems with öäü, too (it created 2 newlines and awkward symbols (like a box))) The checkbox was checked, since then everythings works like a charm.
    – Tw1x
    Apr 15 '17 at 8:57
1

Thanks a lot for the help! Following checkbox was the problem:

https://stackoverflow.com/a/24770092/102182

"Also, and this is key: under Emulation, make sure that Escape non-ASCII input with Control-V is unchecked (i.e. is not set)."

Big thanks to Mikel!

0

This works for me (VIM in Terminal of Mac OS X 10.5.8. (!!)

in the file .vimrc:

set encoding=latin1

set filencoding=latin1

In Terminal > Preferences > Advanced:

  • Escape non-ASCII input

  • Strict VT-100

  • CharacterEncoding: Western ISO Latin1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.