1

I'm dual booting Elementary OS and Windows. I'm seeing two Windows entries though and I'm not sure where refind is finding them.

One is shown as Boot Microsoft EFI boot from ESP and the other is Boot bootmgfw.efi from ESP. Selecting either of them boots with Starting from bootmgfw.efi Using load options ''

My efi directory looks like

/boot/efi/
    Boot/
        BCD
        bcd.trunc
        bootfix.bin
        boot.sdi
        bootsect.exe
        en-us/ 
        Fonts/
        Resources/
    bootmgfw.efi
    bootmgr
    bootmgr.efi
    EFI/
        Boot/
        dell/
        Microsoft/
            Boot/
                bootmgfw.efi
                bootmgr.efi
                lots of other files
            Recovery/
                BCD
                BCD.LOG
                BCD.LOG1
                BCD.LOG2
        PEBoot/
        refind/
        tools/
        ubuntu/
    startup.nsh

My refind.conf has the the entry dont_scan_dirs EFI/dell,EFI/PEBoot,EFI/ubuntu,EFI/Boot

I've tried adding EFI/Microsoft to dont_scan_dirs but both of them still show up.

My disks look like:

sda sdb

I've tried setting dont_scan_volumes to WINRETOOLS,Image,DELLSUPPORT but that doesn't keep both entries from showing up.

Any ideas on what I can include in my conf file so that only one Windows entry shows up?

  • 1
    I see that you have two files: /boot/efi/bootmgfw.efi and /boot/efi/bootmgr.efi which are at the same level as the EFI directory. Could rEFInd be reading those, since they are not excluded in the dont_scan_dirs list, as you had it originally and in the reported test variations? Another possibility is that the dont_scan_dirs exclusion doesn't exclude the named tree, only the named directory. So, excluding EFI/Microsoft is not excluding EFI/Microsoft/Boot. Try explicitly excluding EFI/Microsoft/Boot in the dont_scan_dirs list. – Gypsy Spellweaver Apr 16 '17 at 4:50
  • @GypsySpellweaver Looks like specifying Boot was it. If you want write that as an answer, I'll mark it as such. – Chris May 28 '17 at 1:48
2

The dont_scan_dirs list is a list of directories to skip when looking for efi files. Excluding a directory does not appear to exclude the entire tree at that point. Directories under an excluded one are still searched, just efi files in that explicitly named directory are ignored.

To solve the issue you'll need to include the directories that have the efi files you don't want loaded. In your specific case that means adding EFI/Microsoft/Boot to the dont_scan_dirs list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.